Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After working perfectly for the past 1.5 years I have had my 13" MBA, I suddenly had WIFI issues. Let me give a few details about my experience:

I suddenly had issues connecting to the internet (I was able to connect to the wifi, but could not load a webpage in less than 2-3 minutes if/when it loaded) at my home, but had no issues when connecting directly to my modem via an ethernet cable - thus, it was not a network card issue or an issue with my internet provider.

After that, I had suddenly begun having issues connecting to the networks at my office and school...which is when I began to get frustrated.

See my answer below for how I resolved this issue.

share|improve this question

After having issues with my home, office, and school networks (i.e. all networks I tried connecting to), I realized that the only thing these networks all had in common (besides my computer) was that they were all secured networks.

When I tried connecting to an open network, I had no issues at all - thus my realization that some settings on my MBA got screwed up somehow, and the security authorization was screwing things up.

Resolution: To do a hard reset on your WIFI settings, go into Macintosh HD -> Library -> Preferences (see screenshot below). Remove the SystemConfiguration folder (place it on your Desktop for now). Reboot your MBA.

At this point, I had no issues connecting to any WIFI networks - I hope you have the same result.

enter image description here

share|improve this answer
Removing the whole SystemConfiguration folder is a bit heavy... Just remove the files that you needed to remove. You are "resetting" more than you need/should. – gruberb Apr 4 '14 at 13:22

Instead of removing the whole SystemConfiguration folder, just do the following:

  1. Turn your Wi-Fi off
  2. Open Finder window
  3. Press Command+Shift+G
  4. Enter "/Library/Preferences/SystemConfiguration/" and hit enter
  5. Delete the following files (,, NetworkInterfaces.plist, preferences.plist)
  6. Empty the trash
  7. Reboot your Mac
  8. Turn Wi-Fi back on again
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.