Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My 08 mb, OSX Mt Lion, crashed so I bought new 2012 MBPr. Luckily, I backed everything up. Migrated everything from 08mb over to new MBPr. I noticed that when I deleted files, it skipped the trash can. My home folder did not have me as admin with RW permissions so I had to add myself and give myself RW access.

Before, when I opened iTerm (similar to Terminal), it would say computer name:~ username$. Now, I see an odd hexadecimal name for my computer.

How do I change the hexadecimal code to my computer name?

2012 MBPr after migration assistant

Is this the correct default permissions for Home folder?

enter image description here

Thanks.

share|improve this question
    
Have you repaired Permissions already? –  Thecafremo Apr 18 '13 at 7:10
    
If you go the "sharing" preference pane, it allows you to set a name to your computer. Have you tried that and checking in iTerm? –  jackJoe Apr 18 '13 at 7:53
    
I have repaired permissions. Just changed name of computer in "Sharing" to something else and it still shows that weird unknown20c9d.... –  Danger14 Apr 18 '13 at 19:06

3 Answers 3

up vote 0 down vote accepted

Turns out that my issue was resolved here: OS X computer name not matching what shows on terminal

  1. sudo scutil --set ComputerName "newname"
  2. sudo scutil --set LocalHostName "newname"
  3. sudo scutil --set HostName "newname"
  4. Flush the DNS cache by typing: dscacheutil -flushcache
  5. Restart your Mac.
share|improve this answer

The home folder is supposed to be owned by the user:

$ ls -l /Users/
total 0
drwxrwxrwt   6 root   wheel   204 Apr 13 23:28 Shared
drwxr-xr-x@ 53 lauri  staff  1802 May 11 18:00 lauri

If there are further issues, you could try running sudo chown $USER ~ or resetting home folder permissions and ACLs from the recovery partition.

share|improve this answer
    
Thanks for the link! Very helpful. It hung up on resetting so I had to quit it after a few hours. Still worked though. –  Danger14 May 13 '13 at 15:00

I ran into a similar problem. It sorted itself out after I rebooted the machine and also my wireless router--so I can't obviously know which of the two actually fixed the problem. BUT, this does suggest to me steps (4) and (5) of your solution might be sufficient to solve the problem if you've already named the computer in System Preferences.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.