Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I remember being able to make the edit

defaults write com.apple.NetworkAuthorization ShowAuthUI -bool YES

back in the day, in order to force username/password prompt for users connecting to AFP file servers. I'm experiencing an issue with multiple computers; when trying to connect to a file server on a different domain the user's domain credentials from their current domain are being used, and not the domain credentials needed for that specific file server on the mentioned domain.

That's why I would like a solution like the one above known to work with Mountain Lion, which that one is not.

I've also tried clearing out and removing the keychain, browsing bonjour through Finder (which still allows a "connect as" login box to be pulled up) but the server, being on a seperate domain, is not showing up.

Any known solutions or suggestion? My workaround currently is to "connect to server" using afp://username:password@fileserver.domain.com doing that allows proper authentication to occur and/or pops up the username/password dialog prompt. That is a fine workaround for me, but our hundreds of users would not appreciate the added complexity.

share|improve this question
1  
Have you ever found a solution for this? I'm working on next school year's installation now and scripts which worked for years now run into this issue. –  NomadNYC Jun 26 '13 at 16:15
    
Unfortunately, no. I instead used the workaround I offered in the original post. –  TryTryAgain Jun 26 '13 at 17:05

2 Answers 2

I just found that if you use IP address instead of name of server 10.8 does prompt you for username / password! Why? I have no idea.

share|improve this answer
    
That's good to know, thanks for sharing. Unfortunately, we rely heavily on DNS as IPs may change. –  TryTryAgain Jun 26 '13 at 18:09

I was struggling with this one as well and I managed to find the answer. The key is the server command line utility serveradmin

The following KB article for Snow Leopard got me going on the right track. I can't seem to locate a similar article for 10.8. http://support.apple.com/kb/PH8440

When you use it to read the settings for the AFP service you should see that authenticationMode is set to standard_and_kerberos. Resetting the parameter to standard will force the username/password prompt.

Here is what I did

  1. Export the current settings incase something goes wrong

    sudo serveradmin settings afp > afpsettings.txt
    
  2. Stop the service

    sudo serveradmin stop afp
    
  3. Check that the setting is in fact “standard_and_kerberos”

    sudo serveradmin settings afp:authenticationMode
    
  4. Change the settings

    sudo serveradmin settings afp:authenticationMode = "standard"
    
  5. Verify the change

    sudo serveradmin settings afp:authenticationMode
    
  6. Restart the service

    sudo serveradmin start afp
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.