Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

iMessage won't verify my phone number. When I try to select my number for messages to be sent, it's greyed out. So I receive my iMessages over email which I don't want to do.

I've tried: turning iMessage on and off, resetting network settings, rebooting my phone and nothing's worked.

Any ideas?

share|improve this question
    
What happens when you turn iMessage on on your iPhone? What does it display in text below the iMessage on-off control? Where exactly are you "trying to select your number for messages" and finding it greyed out? –  Old Pro May 19 '13 at 21:20
add comment

3 Answers 3

Looks like you tried all the basic troubleshooting steps. Heres the next step:

  1. Make sure your data is backed up, either iTunes or iCloud.
  2. Turn iMessage off (make sure to do this).
  3. Erase all contents and settings (this will wipe your device.) Settings > General > Reset > Erase All Contents and Settings.
  4. Set the phone up as New (make sure to do this)
  5. Turn on iMessage, wait for it to activate. Once it's activated erase the phone again and restore from your backup.
share|improve this answer
add comment

You need to sign in to iCloud on your iPhone before it can receive messages via iMessage. After you do that, you can even receive iMessages sent to your email address if you register the address with your Apple ID.

share|improve this answer
add comment

This was an easy fix for me:

  • Backup on iCloud if you feel like you need to
  • Turn off your iMessage
  • Go and delete all your network settings
  • Let the phone restart
  • Turn on the iMessage again, wait for 10 seconds or so
share|improve this answer
1  
This seems similar to what the OP says they tried and didn't work? Also more/less same as first answers? –  beroe Oct 2 '13 at 20:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.