Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a problem making xip.io works. I have set up my machine to use virtualhosts with MAMP .local domain name.

this is my httpd-vhosts.conf file:

NameVirtualHost *:80
UseCanonicalName Off

<VirtualHost *:80>
    VirtualDocumentRoot /Users/<myusername>/Sites/%-1/%-2+/build
    <Directory "/Users/<myusername>/Sites">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

When I try to access for example http://project.local.<my local ip>.xip.io it doesn't work while http://project.local works. How can I fix this?

Also, I have read that the .local domain on Mac can cause some problems, is this true?

share|improve this question
    
On OSX .local is used by Bonjour for local discovery of ips by name without using DNS (see RFC 6762 –  Mark Apr 15 '13 at 10:07
    
Have you edited the hosts file? –  jackJoe Apr 15 '13 at 15:18
    
yes, my Hosts file is edited –  John Apr 16 '13 at 5:30
add comment

1 Answer

I use MAMP Pro and the file httpd-vhosts.conf does not contain this setting, but in the app I have this:

ServerAlias example.*xip.io

The host is http://plugins.dev and if my memory serves me well, it's all that's needed to have it working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.