Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I first configured my new iPod touch 5th gen, I put "English" for iOS language. I then switched iOS to "Français (Canada)" in the General Settings/International. Everything look fine except one thing : The date displayed on the lockscreen which remains in english (Ex: Monday, 15 April). Even after restarting my iPod, the date is still in english.

Any idea how to have the date translated on the lockscreen ?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Under Settings -> General -> International, you need to change the Region Format settings to specify your desired region; I'm assuming you only changed the Language settings.

When I change Region Format to French -> Canada, my lockscreen appears with the correct French date format: mardi 16 avril.

share|improve this answer
    
Kinda confusing, since when I go in Settings -> General -> International, Region Format display only Canada, so I did not bother looking there since I thought it was already correct. BUT French -> Canada is not part of the available values there. It just switched to a random Region, went back and reset it to Canada and then it worked o_O –  MaxiWheat Apr 16 '13 at 20:09
    
Bizarre. When I tapped French in the Region Format listing, I was taken to a screen that lets you pick *sub-*regions, and that's where I chose Canada. Glad you got it sorted. :) –  Dan J Apr 16 '13 at 20:17
add comment

The format and language of Date & Time (and other units of measure) are set in Settings -> General -> International -> Region Format.

These can be set independently of the language used throughout the rest of your iOS device.

share|improve this answer
add comment

Check out by going to Settings --> General --> Date & Time.

share|improve this answer
    
There isn't a language config there. There are 3 settings : 24-hour time, Set automatically and Time zone. –  MaxiWheat Apr 15 '13 at 11:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.