Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a wireless network that I set up using a Linksys WRT54G router. There I can add MAC addresses of client devices that can access my network.

I've added my iPhone's MAC address to this list, but my iPhone doesn't detect my network. What can I do to allow my phone to detect my network?

share|improve this question

migrated from serverfault.com Apr 14 '13 at 22:13

This question came from our site for professional system and network administrators.

1  
If you have MAC filtering turned on, do you also have the BSSID Broadcast turned off (both "security" measures common in home networking)? Have you used your iPhone to connect to other Wi-Fi networks to make sure it works? –  Chris S Apr 14 '13 at 22:15

3 Answers 3

up vote 2 down vote accepted

If you don't see your network's SSID in the iPhone's list of Wi-Fi networks, you can always try the Other option in the Wi-Fi settings screen to manually input the SSID and security settings.

iPhone Wi-Fi settings

If that doesn't work, you'll probably want to turn on SSID broadcast and temporarily disable your MAC filtering to troubleshoot the issue.

share|improve this answer
    
Thanks, enabling broadcasting solved it. –  Henrique Ordine Apr 15 '13 at 5:53

Do you have broadcasting of SSID turned on? If no, turn it on at least until you connect your iPhone to this network.

Turn off MAC address filtering until you connect your iPhone. Then add your iPhone's MAC address to the list (from the list of connected devices) and turn filtering back on. This way you will be sure you did not misspelled your MAC address.

share|improve this answer

There is also getting very close to your router/base station (this is a real tip) ... and I find that Forget This Network has to be run, otherwise the iPhone hangs onto the 169.xxx.xxx address forever and the user doesn't know it ...

I hope, as well, you are using Airport Utility. Try setting up a Guest or open network first and see if you can't automatically join that. Subsequently changing its settings to your password network works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.