Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When accessing the internet from my home connection, Google Chrome has trouble accessing certain sites that use https. These include Google search, Facebook and discussions.apple.com, but for some reason Gmail is ok. This is on a Retina Macbook Pro with 10.8.3 Mountain Lion.

Given the symptoms described below, it the issue seems likely to be some misconfiguration of the router, which unfortunately I'm not in a position to change. However, since it works in Safari but not Chrome, the two browsers must be doing something differently. What I would really like to know is how I can diagnose what this difference is.

What happens when I try to access the site varies depending on the site. Google search works intermittently, and when it doesn't work it times out as if the server was down. Facebook.com consistently renders the first two wall posts but then stops loading. The Apple forums just sit there forever with a white screen.

I can access these sites just fine in Safari, and they also work fine when I'm browsing via the WiFi at work. It's only when I'm (a) using the ethernet cable at home, and (b) using Google Chrome that the problem occurs. Unfortunately I have no access to the router at home, because the internet is part of my rental agreement and I just have an ethernet socket in my room.

I have tried the following things (and possibly more) to no avail:

  • Clearing all brower data in Chrome (cache, cookies etc.)
  • Disabling all extensions and restarting Chrome
  • Switching to Google public DNS
  • Checking my proxy settings in OS X. (No proxies are configured. Both Safari and Chrome use the system settings.)
  • Checking that my IP address is the same when browsing via https from Chrome and Safari (it is.)
  • Looking for any suspicious messages in Console. (There are several about things relating to Spotlight, but nothing relating to Chrome, and nothing comes up when I try to load these sites.)
  • Disabling "Predict network actions to improve page load performance" in Chrome preferences. This changes the symptoms slightly (Facebook times out instead of displaying the first two wall posts; other sites behave the same as before) but does not resolve the issue.
  • Rebooting into safe mode
  • Deleting my Chrome profile
  • Deleting all the other files in ~/Library/Application Support/Google/Chrome
  • Setting ipv6 to "Link-local only" in system preferences
  • Turning off ipv6 completely by running networksetup -setv6off Ethernet in Terminal
  • Accessing the web via TOR. The problem does not occur, but the connection is too slow for regular use.

My question is, what else can I do to try and work out what the problem is? Chrome is obviously doing something different from what Safari does when trying to access these sites, and I'd like to know what that is, with a view to either solving the problem for myself, or at least being able to submit a bug report to whichever party is responsible.

share|improve this question
    
What Chrome version do yo have? –  Buscar 웃 Apr 12 '13 at 15:16
    
@Buscar웃 version 26.0.1410.65. It is the latest version according to "About Google Chrome". –  Nathaniel Apr 12 '13 at 15:31
add comment

3 Answers

This appears to be a bug with Chrome and XP. There appears to be no resolution.

share|improve this answer
add comment

Have you tried using the incognito mode? Shift+Command+T+N and trying the websites again from that page?

share|improve this answer
    
I guess it can't hurt to try. This problem hasn't happened for a while, but if it happens again I'll give that a go. –  Nathaniel Oct 11 '13 at 2:54
add comment

You did eventing right except for one step.

Making new account.

Quit Google Chrome completely.

Go to the Go menu > Go to Folder.

Enter the following directories in the text field, then press Go. ~/Library/Application Support/Google/Chrome/

Locate the folder called "Default" in the directory window that opens and rename it as "Backup default."

Try opening Google Chrome again. A new "Default" folder is automatically created as you start using the browser.

Alternatively you can "teach" your browser.

That is done by adding the :80 to the web address.

Example www.myseite.com:80

Also run the netstat -a -p tcp to see if https (443) are open)

Last not least, turn off the experimental "Built-in Asynchronous DNS" is Disabled in chrome://flags/

share|improve this answer
    
Thanks for the answer, but I already tried this. (It's what I meant by "deleting my Chrome profile".) Even after doing this the problem still persisted. –  Nathaniel Apr 12 '13 at 15:32
    
You mentioned from "Home", does it work on another network ? –  Buscar 웃 Apr 12 '13 at 15:41
    
there might be an issue with how your system handles the sites certificates. Try adding :80 (any site).com:80 if that doesn't work try 443 for secure http (any site).com:443 –  Buscar 웃 Apr 12 '13 at 16:08
1  
It could well be a problem with the router - as I said, I unfortunately don't have access to the router, since my internet is provided directly via an ethernet socket in my room. But if the problem is with the router, it seems weird that it would affect only Chrome and not Safari. –  Nathaniel Apr 12 '13 at 16:45
3  
adding :80 just means you're explicitly going to port 80 and are no longer accessing the site via https. IMO this is not a great solution to your actual problem. –  dstarh Apr 12 '13 at 20:48
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.