Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Due to my email backup software, I had to create 'real' users on my 10.6.6 install rather that create 'share only' users.

Now when users connect to the shares, they see a full home folder as well as the shares I have setup.

Is there a way for me to turn off sharing home folders?

EDIT:

When a user logs onto the server, I only want them to see the assigned shares, not the automatically made 'home folder' share. For instance, I make a user on the server called 'Bob', and three shares called "One', 'Two', 'Three'. When Bob logs onto the server from another computer via finders 'SHARED' list, he sees four shares 'Bob', 'One', 'Two', 'Three', I do not want 'Bob' to show up on that list.

share|improve this question
    
This doesn't answer your specific question, but permissions on your home folder will prevent people from looking at your stuff so i wouldn't worry about it being on (unless you changed the permissions). If you didn't, the only thing they would see is Public, Sites and every other doc you created in the root of your home (with +r to group / others ) –  user3814 Feb 21 '11 at 10:18
    
@gbrandt does the backup software use the share-only-users' home folder, or is it that just an account is needed? (much like a system account for processes) –  Iain Feb 21 '11 at 15:19
    
The backup requires a full user on the computer, a shares only user does not work, I tried. I am backing up mail from our mail server in the CoLo, to a local machine in a fashion that allows our local machine become the mail server in emergencies. (SL Server in Colo, SL Client local) –  gbrandt Feb 21 '11 at 16:41
    
@geermc4 I do not want users storing data in those home folder shares. So I don't want to give them access at all. –  gbrandt Feb 21 '11 at 20:42
    
could you tell us what the email backup software is? I'm curious as to why it needs a real user. –  Iain Feb 22 '11 at 3:46
show 3 more comments

3 Answers

up vote 1 down vote accepted

If you set up their accounts in the Accounts pref pane on the server as "sharing only" then they will only get access to shared folders set up in the Sharing pane of System Preferences.

See the Apple docs on creating a sharing only account.

Since you say the email backup software requires that the user has real folders, then you can't remove them as "shares", they have full access to these folders and the server will advertise that.

Without knowing why the email software requires the user to have folders then a workaround is difficult to find.

share|improve this answer
    
Not an option, the users must have proper directories for my email backups to work. –  gbrandt Feb 22 '11 at 2:12
    
So? Folders shared via a sharing only accounts are as real as they get. –  patrix Jul 21 '12 at 11:11
add comment

I'm not sure if I understand your question :)

There is an option to select which folders are shared, in:

System Prefences > Sharing > File Sharing

share|improve this answer
    
i want sharing to still work, since I share other folders. I just don't want the users home folder to show up in the list of shares. –  gbrandt Feb 20 '11 at 22:08
    
But you can select and deselect which folders are shared, in that option. If I'm still getting your question correct :D –  deiga Feb 20 '11 at 22:16
    
for what I understand of the question (which is not really clear), what deiga is saying is right. Selecting File Sharing in the list on the left shows on the right options to add or remove folders that are shared. You would probably have to do that for every user though. –  Mortimer Feb 20 '11 at 22:26
1  
What the OP is saying is that whenever you connect with a real account (and not a sharing-only one), that real user's home folder is automatically visible as a read-write folder. So if user "peter" connects and puts his password, he'll have a peter's home folder available (and only peter will have access to that). He wants to remove Peter's Home from the possible list of shares, something that the UI of the File Sharing screen doesn't allow. –  Martín Marconcini Feb 22 '11 at 6:06
add comment

This is the behavior of the server one connects to when a home directory is specified in the local user database. So, my local account is created and by default I have a home folder. When I connect to that server remotely, it will present me with that home directory as a Sharepoint.

You can go into Workgroup Manager, select the user, and select the "Home" tab/button. You should have a few options there, one of which is "none." Select that and the user will no longer see a home directory when connecting to the server.

The only problem with this is the Preferences User & Groups app isn't smart enough to figure out this was done in workgroup manager, and it prevents you from looking at the Advanced Options for the user. Shouldn't be a big deal if you have WM though.

t

share|improve this answer
1  
Not a clear answer, assumes the person knows what Workgroup Manager is -- they didn't say they were running OS X Server, so they probably don't have WM. –  gosmond Feb 23 '13 at 7:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.