Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On OS X server using the wiki feature, I want to embed a youtube.com video onto a page. I thought the process would be to switch to HTML coding when making the Wiki Entry and cut and paste the HTML embedded like tag of youtube video into the post along with all the other content.

<iframe width="560" height="315" src="http://www.youtube.com/embed/mylinkaddress" frameborder="0" allowfullscreen></iframe>

When I save the page, it doesnt show up.... which makes sense since when I go back to edit the page and view the HTML, the tag is no longer there. It seems like OS X server is rejecting the tag as invalid when saving the page.

How can I get OS X server to support embedding video into pages?

This occurs on the blog and wiki.

Update: this is the Wiki Server

share|improve this question
add comment

2 Answers

I had the same problem.

On the Server load terminal.app in your Utilities folder, and type in:

On Mountain Lion:

sudo defaults write /Library/Server/Wiki/Config/collabd.plist FiltersEnabled false

On Lion:

sudo defaults write /etc/collabd/collabd.plist FiltersEnabled false

You may need to turn the Wiki Service off and on afterward for the settings to take affect. You can do this by typing:

sudo serveradmin stop wiki

then

sudo serveradmin start wiki

in the Terminal.

share|improve this answer
    
Neither of those paths exist on Mountain Lion Looks like the path is /Library/Application Support/Apple/WikiServer but that didn't work either with this fix: discussions.apple.com/thread/3147233?start=0&tstart=0 –  DogEatDog Apr 8 '13 at 14:03
    
What version are you using? (e.g. 10.8.3) –  glenstorey Apr 8 '13 at 17:19
add comment

After trying this solution and editing the following file

/Library/Application Support/Apple/WikiServer/whitelist.plist

I then realized that I needed to add the tag from this article... duh

What I added was this the following XML to it:

        <key>iframe</key>
        <array>
            <string>frameborder</string>
            <string>title</string>
            <string>width</string>
            <string>height</string>
            <string>src</string>
            <string>allowfullscreen</string>
        </array>

The wiki server then needs to be cycled

sudo serveradmin stop teams
sudo serveradmin start teams

Here is the full plist configuration

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.