Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Today I was cleaning my MacBook keyboard (OSX 10.6.6) while the user was locked. Due to some random key-presses, the language of the login changed from English to Hebrew (I use both in MAC, but only English for login). When in the login menu, the cmd-space shortcut has not effect, and it does not change the language.

I didn't have any way to change it, and was practically locked outside my account.

What is the magical key-sequence that can change the language back to English?

(for completeness - I did a hard reboot, which brought me back to the main login screen, and luckily the language reverted back to English... Now I have changed the login preferences so that the language selection appears in the login screen anyhow, but the question is very important for anyone who found himself locked out.) see also Question in superuser stackexchange and also This Question, that is very useful if you are not already locked - so you can set the language drop-menu to appear also in the login menu.

share|improve this question
1  
If you fixed it yourself, please add what fixed it as an answer. –  Mark Szymanski Feb 20 '11 at 21:06
1  
BTW, turn off your mac before cleaning it! –  Loïc Wolff Feb 21 '11 at 8:53
    
@Loïc, this lesson was learned in the hard way.. –  Ran G. Feb 21 '11 at 18:46
    
@Loïc you can always use Keyboard Cleaner: jan.prima.de/~jan/plok/archives/48-Keyboard-Cleaner.html ;) –  Martín Marconcini Mar 22 '11 at 17:16
add comment

2 Answers

The keyboard shortcut is customizable, just as almost any other action. The place to customize and thus find the shortcut is:

System Preferences > Keyboard > Keyboard Shortcuts > Keyboard & Text Inputs > "Select previous input source" & "Select next source in Input menu"

These are cmd+space and opt+cmd+space as defaults on my OS X 10.6.6

share|improve this answer
    
cmd+space does not work in the login screen, unless specifically enabled. –  Ran G. Feb 21 '11 at 6:22
add comment

This adds the language selection to the login window:

  1. From the Apple menu, choose System Preferences.
  2. Click Users & Groups to display the pane (or choose User & Groups from the View menu).
  3. If the lock icon in the lower-left corner of the window is closed, click it, then enter the name and password of an administrator to unlock it.
  4. Click Login Options.
  5. Select the "Show Input menu in login window" checkbox.

Source: http://support.apple.com/kb/ht4099

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.