Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am experiencing an issue with OS X 10.8.3, where it takes a very long time to login. It seems like it has something to do with which network I am connected to.

Explanation of the issue:

  • I get home from the office and wake my MacBook Air up from sleep
  • I login with my regular account (in these groups: Admin, Managed, Mobile)
  • It can anywhere 15 seconds and several minutes before I get logged in

While I'm at the office, it takes less than 1 second to login; it's pretty much instantaneous. The interesting thing is that, it seems like it only occurs the first time I login from home, or subsequent times if the computer has been sleeping for a longer period of time.

It seems like it's somehow related to which wired/wireless network I am connected to; as if it's trying to authenticate with something before logging me in. I've tried many different things (turning on/off wireless, VPN, changing user groups, etc.) but I haven't been able to determine the source of the problem.

Has anyone here experienced something similar?

Many thanks in advance,

– Leif

share|improve this question
    
so you can login fine (in seconds) without network –  Buscar웃 Apr 7 '13 at 10:51
    
did you try logging out from work network before going home? it might be it is somehow looking for work network it was on before going to sleep. –  Buscar웃 Apr 7 '13 at 10:57
1  
let me get that, going from home to work no problem, going from work to home problem. what network activity does your MBA does at work? also try turning the MBA OFF, not just sleep mode. –  Buscar웃 Apr 7 '13 at 11:10
    
Thanks for the tips, I'll give it a try. I haven't tried logging off explicitly. I'll try that next week :) –  Leif Apr 7 '13 at 12:19

1 Answer 1

You mention it is/was a work account. Also that it is a managed account. Would you happen to be connecting up to an Active Directory or other directory account? If so, your directory server could be specifying that your account try and connect up with a network share on login. If your connection is wireless or something that passes login credentials in order to authenticate to the network, this may well create significant lag on login.

To test, fire up Terminal and enter:

dsconfigad -show

If the "Mount home as sharepoint" value is set to Enabled, your account is likely trying to connect to a share on login. To prevent this, simple run the following command:

dsconfigad -sharepoint disable

Note: this is all assume Active Directory connection, being one of the more popular enterprise/work domain services.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.