Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I’ve just bought a new Mac with 10.8.2 pre-installed. When I started it up for the first time, once I’d gone through the initial set-up, the App Store launched, and showed me an iPhoto update, and some system updates including Mac OS X 10.8.3.

I quit the App Store, set up another account on the Mac to be my admin account, and edited my main account so that it wasn’t an admin any more. I restarted the Mac, logged in with my main (i.e. non-admin) account, and opened up the App Store again to install the updates.

The iPhoto update showed up, but the systems updates didn’t.

I installed the iPhoto update successfully. I then changed my main account back to being an admin account, thinking that maybe somehow that affected updates. I restarted the Mac, logged in using my main account (now an admin account again), and re-launched the App Store. Still no 10.8.3 or system updates listed.

Any idea what’s going on? On my old Mac, running 10.7, my main account was non-admin, and I didn’t have any problems installing OS X updates.

share|improve this question
    
You mean the initial configuration was already done? Someone might have chosen to ignore that update. –  Ryccardo Apr 5 '13 at 21:05
    
@Ryccardo: ah: no, I did the initial configuration myself. (And after that was done, saw the 10.8.3 update in the App Store’s updates tab. I just haven’t seen it since my first restart, and About This Mac says I’m still on 10.8.2.) –  Paul D. Waite Apr 5 '13 at 21:19
add comment

3 Answers 3

up vote 1 down vote accepted

I had exactly the same issue: Brand new out of the box MacBook Pro 13" 10.8.2 preinstalled. Went through exactly the same process outlined by the OP.

Resolved by:

  1. Closing the App Store
  2. Restarting App Store
  3. I then went to Store > Check For Unfinished Downloads

The 10.8.3 update then reappeared and I was able to redownload and install.

Hope this helps

share|improve this answer
    
Sounds worth a try. I didn’t take those steps when I had the issue, but they might have fixed it like they did for you. Many thanks for sharing. –  Paul D. Waite Apr 13 '13 at 11:13
add comment

I just launched iTunes, and it told me there was a new version of iTunes available. I clicked on the “Download” button, and it opened up the App Store, which now shows all of the system updates I saw before, including Mac OS X 10.8.3, along with iTunes 11.0.2.

No idea why it forgot about them for a while, or if I would have been able to get them back if there wasn’t an iTunes update due. (I’m sure I would eventually.)

share|improve this answer
add comment

I just unboxed my new iMac 27" i7. Clean setup with no migration, I did sign into iCloud. I ran updates first thing when getting to the desktop. Updates for 10.8.3, iPhoto, Airport Utility, Camera Raw and one other I can't recall. I hit restart and an error appeared stating the packages may have corrupted and to try the install again after restart. I did so and now it says No Updates Available.

What a drag

share|improve this answer
    
Very odd. You might want to try starting iTunes to see if that prods Software Update back into line, like it did for me. –  Paul D. Waite Apr 7 '13 at 13:30
    
Hmm - this seems like more a related issue than something to be of use here. The OP is looking to get 10.8.3 - and you've clearly downloaded that so it's not clear how problems post-10.8.3 relate to someone wanting to see 10.8.3 in the store in the first place. –  bmike Apr 7 '13 at 19:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.