Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Possible Duplicate:
The browser doesn't show videos on Youtube

Youtube videos appear as a black box only in safari 5.0.3, since flash payer has been updated to 10.2. They work if I change the User Agent to Safari 4.0.3 using the Developer menu, but this is not permanent.

Flash Player 10.1 is no longer downloadable, so I don't know how to downgrade. User agent setting are not permanent, or I don't know how to set them fixed.

Maybe, it is a bug in YouTube embedding, because Flash sites like that from Adobe work. I am relativly sure that the new flash plugin is the problem, because I have to macbooks with OS X 10.6.6 and Safari 5.0.3. The only difference if the version of the flash plugin: 10.1 shows youtube videos, 10.2 not.

I'm not sure the flash version is the reason. ALso the working mac has been installed with OS X 10.6 from scratch, the not working has been updated from an 10.5.

share|improve this question

marked as duplicate by Nathan Greenstein Apr 10 '11 at 14:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Possibly a duplicate of - apple.stackexchange.com/questions/8793/… –  LC1983 Feb 20 '11 at 19:43
    
I have the same problem - just updated to flash 10.2 and voila - black box in you tube! Works ok in firefox - must be a safari-flash issue ? –  user4116 Mar 3 '11 at 0:25

3 Answers 3

Try to start Safari in 32Bit mode (right click on it, chose "information" and check "32-bit mode".

Another idea: uninstall flash completely so safari should display HTML5 videos in youtube without a plugin.

Hope, that helps!

share|improve this answer
    
Uninstall Flash is not a possibility in the moment, because other sites do not support HTML 5 in the moment. –  Arne Burmeister Feb 21 '11 at 11:08

I had this problem while running ClickToFlash 1.6b9 (the original general browser plug-in, not the Safari 5.x extension). Even with ClickToFlash disabled via the checkbox in ClickToFlash's preferences, it still happened. I ended up dragging the ClickToFlash plug-in out of /Library/Internet Plug-Ins/ and restarting Safari, and it went away.

share|improve this answer
1  
I do not have installed ClickToFlash. –  Arne Burmeister Mar 3 '11 at 7:47

I can't fix the bad version of Flash that you have, but I can offer a solution to get YouTube working. YouTube supports formats other than Flash. If you are using Safari, download and install this Safari 5 Plugin called YouTube5

Once this extension is installed in Safari 5, when you go to the YouTube site, instead of getting flash videos you get a custom HTML5 player. Works great and I don't miss flash.

Here is a screen shot of how I have it setup in my Safari 5 Extensions panel of Preferences.

Safari 5 Extension Preference Panel

Hope this helps!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.