Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have my screen saver set to Arabesque. If I move my mouse down to the Screen Saver hot corner, I get Arabesque. If I sit and wait for the screen saver to start automatically, I get Arabesque.

But if I leave my computer for any length of time and come back to it, it's almost always on Message, putting the name of my Mac up for everyone to see. I dislike this behavior. If I go to System Preferences after this happens, it's still on Arabesque, it's just ignoring the setting.

What's going on? Is there any way to fix it?

share|improve this question
1  
Do you lock your computer before leaving it? If so, you might be getting other settings than your own user's. You might want to try the suggestions here: apple.stackexchange.com/questions/6336/… –  Lizzan Apr 2 '13 at 6:37
    
D'oh, yes, I should have thought of this. That question led me to this answer on a different question which was exactly what I needed. Add an answer to that effect and I'll mark it correct! –  75th Trombone Apr 2 '13 at 14:54
add comment

2 Answers

up vote 1 down vote accepted

If your computer is locked, the screensaver settings for the root user account is used instead of your own. You can change those settings according to the answer to this question: How can I set the Mac OS X screensaver when not logged in?

share|improve this answer
add comment

"Almost" always? Uncheck the use random screensaver button in the Desktop & Screen Saver preferences.

enter image description here

share|improve this answer
    
If you had read my question you would have seen that Arabesque was indeed selected, not Random. –  75th Trombone Apr 2 '13 at 14:47
    
I read your question. No need to be rude. Selecting Arabesque has nothing to do with the state of the "Use random screen saver" checkbox. I was just trying to be helpful. Maybe you should edit your question to more accurately describe your problem. –  Jason Conrad Apr 2 '13 at 17:40
    
Ah, I see. Mountain Lion doesn't have that checkbox there. "Random" is an option along with all the other screensavers. Even so, the behavior I described doesn't fit your assumption, and I thought you were a bit sarcastic in your answer. I do apologize if that wasn't your intent, and I un-downvoted you. –  75th Trombone Apr 2 '13 at 23:02
    
Thanks. I'll un-downvote your question as soon as i'm able. Right now, my vote's locked in unless the question is edited. –  Jason Conrad Apr 3 '13 at 1:03
1  
done. cheers, mate. –  Jason Conrad Apr 3 '13 at 1:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.