Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

It's impossible to put it on DFU mode because it won't turn off and I don't know what to do.
iTunes won't recognise it either.

How can I fix this?

share|improve this question

1 Answer 1

I fixed it. I won't delete the question because I think this may help other people... but if mods want to delete it, then go ahead.

Today when I woke up the battery had died again, so I took advantage of this (because now it won't turn on everytime I tried to turn it off). Redsn0w has an option to boot the iphone/ipod if it's off while on tethered jailbreak, but it won't work with iphone 4S because it has A5, not A4; but I used the DFU instructions there to make sure it was done correctly (there's no screen that will tell you it's on DFU mode, but redsn0w will pop up a message telling you it doesn't support your device). Then I opened iTunes and it recognized it now and asked me if I wanted to restore it, and that's it... at least it works now.

In fewer words:

  1. Let the battery die.
  2. Plug it on your computer and let it charge for a minute or so.
  3. DO NOT turn it on. Try to put it on DFU mode (if you don't know how or need to be looking at the instructions with the seconds needed on each button then download RedSn0w and cick on Extras>Boot).
  4. Start the phone and go to setting reset and reset the phone and cydia or tethered jailbreak will removed from your device
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.