Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Awhile back, I symlinked my ~/Library/Mail Downloads directory to ~/Downloads so that my email attachments would be downloaded to the same location that all my other applications download files to.

When I upgraded to Mountain Lion, I noticed that the Mail Downloads folder had been restored. So I deleted it and recreated the symlink the same way I did for previous versions of OS X.

Now, every time I try to download or quick-look an attachment in mail.app, I see the following error (might not be exact; translating from Spanish):

Mail was unable to save the attachment "..." to disk. Make sure that the downloads folder has write permissions.

Some of the fixes I have tried:

  • Making ~/Downloads world-writable.
  • Removing the symlink and re-creating the directory.
    • Making that directory world-writable.
  • Repairing permissions via Disk Utility.
  • Changing the location of the Downloads Folder preference for Mail.app to ~/Downloads.

How do I restore the functionality of my Mail Downloads folder (preferably so that it is symlinked to my home Downloads folder)?

share|improve this question
    
Silly question: have you tried changing the "Downloads folder" preference in Mail.app? –  jmk Mar 30 '13 at 4:44
    
lol That is a good point; I forgot about that. Unfortunately, changing the preference to my home downloads folder does not solve the issue (although perhaps it helps pinpoint the problem). I will update my question. –  todofixthis Mar 30 '13 at 13:50

1 Answer 1

up vote 3 down vote accepted
+50

Assuming Mountain Lion...

  1. Quit Mail
  2. Delete the ~/Library/Mail Downloads folder.
  3. Delete the ~/Library/Containers/com.apple.mail folder.
  4. Restart Mail
  5. Rebuild Mailboxes
  6. Set your Downloads folder in Mails preferences to ~/Downloads.

    Screenshot of Mail.app preferences dialog with downloads folder highlighted

Better?

share|improve this answer
    
Maybe just try to set the downloads folder directly in preferences before deleting com.apple.mail. –  patrix Apr 15 '13 at 12:11
    
Sweet. That did it. Thanks so much for your help! –  todofixthis Apr 15 '13 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.