Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am seeing attached icon in the top right menu bar. I tried deleting MenuExtras by going to /System/Library/CoreServices/Menu Extrasbut it didn't help, please help to hide or remove it.

enter image description here

share|improve this question
up vote 46 down vote accepted

That item is the VMWare fusion menu bar icon.

The vendor has this article and steps to allow you to disable and configure it.

http://kb.vmware.com/kb/1015330

To modify the behavior of this feature:

  1. Go to Virtual Machine > Settings.
  2. Click Application Menu (Applications in Fusion 3).
  3. Click the Applications Menu tab if using Fusion 3.
  4. From the Show applications menu in menu bar drop-down, choose Always, Never, or Only when Fusion is running.
share|improve this answer
    
thanks @bmike♦ and @J Novack – seoppc Mar 27 '13 at 21:05
4  
In later versions of VMware Fusion this setting has been moved to the general preferences of VMware Fusion, and not related to the specific virtual machine. So from the "VMware Fusion" menu, select Preferences and the setting is now under the General tab. I have Fusion 8, I don't know when they moved this setting. – Lasse V. Karlsen Oct 12 '15 at 9:54
2  
Also, go to System Preferences > Users & Groups > username > Login Items, and remove the VMWare launch application. – Patrick McMahon Mar 14 at 5:08

That's the VMware Fusion icon.

  1. Click it.
  2. Select "Application Menu Settings...".
  3. Modify the dropdown next to "Show Applications menu in menu bar" to be "Never".
share|improve this answer
    
Nice! I didn't realize you could control it from the icon as well. My guess is the OP has a partial install and the icon could be malfunctioning. We'll see if they need uninstall help or just pointing to the right software is all they need to solve this. – bmike Mar 27 '13 at 20:49
    
unfortunately, this doesn't work if the VM was deleted. – Sarge Borsch Nov 27 '14 at 8:41

It looks like the option is no longer configurable in vmware fusion 8, or maybe I didn't look in the right place. I had to kill it and rename it to prevent it from running. Haven't had obvious adverse effect yet. So, open a terminal

ps -fx | grep -i vmware
kill xxx # the pid number, such as 51889
sudo mv "/Applications/VMware Fusion.app/Contents/Library/VMware Fusion Start Menu.app/Contents/MacOS/VMware Fusion Start Menu" "/Applications/VMware Fusion.app/Contents/Library/VMware Fusion Start Menu.app/Contents/MacOS/VMware Fusion Start Menu.bak"

For someone who doesn't like command line, just rename the file, logout and login.

share|improve this answer
    
In Fusion 8, it's configured globally under general settings – john cs Dec 14 '15 at 4:38
    
Thanks! Finally found it. – YH Wu Dec 18 '15 at 4:39

I had the same problem in El Capitan

I selected "Never" but the icon kept reappearing after every restart.

However, after I created my first virtual machine, the "Never" option held and the icon has remained hidden.

Sounds crazy, but true.

share|improve this answer

I had this icon appear after log in today. I do not have any virtual machines. Another user has VMWare Fusion installed.

Here's how I solved it without messing with the installation.

  1. I used part of YH Wu's answer to kill it. If you don't understand the commands, use Wee Malcky's answer. (See below for these two methods.)
  2. Remove it from your Login Items at: System Preferences > Users & Groups > Login Items

YH Wu Method

ps -fx | grep -i vmware
kill xxx   # the pid number, such as 51889

Wee Malcky Method

  1. Open Activity Monitor app
  2. Click the CPU tab if you have one
  3. Search for "fusion"
  4. Select the process
  5. Click the Force Quit button in the top left of the window if you have it. Otherwise, try right-clicking and selection something like "Kill" or "Force Quit."
share|improve this answer

spotlight -> activity monitor -> search for fusion -> kill the process

share|improve this answer
2  
Forgive my negativity but while this procedure most probably will remove the icon it's rather doubtable this is the solution the OP - if not anybody - is looking for. Pulling the power plug will also remove the icon. – EDP Dec 2 '15 at 6:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.