Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've set up sharing of my MacBook on my home network. It doesn't show as visible but I can access it at \jdxmacbook from the Windows PC.

However when I try to copy a file, it starts OK but after about 10s I get a "can't access" folder error. However from Explorer I can still view the MacBook folders just fine.

enter image description here

I don't have a USB stick with a spare 2Gb for the file so if I can't get this to work, I'm screwed... it happens every time

What is causing this problem when I see no problems transferring large files between other devices on the network? It seems to be either a problem with OSX, or OSX/Windows communication, or the router in some way...

share|improve this question
If you can't get the network transfer to work, you can download a zip utility that can break up what you are trying to transfer into chunks (like 200 MB) and copy it a chunk at a time.. – vcsjones Mar 24 '13 at 20:36
Would you mind making an edit to the end of the question? Are you looking for alternatives to file transfer (hence a software-recommendation question to be solved) or ask how to debug / troubleshoot a failed file transfer from OS X serving the file to Win-7 as the client? It's clear you want a solution, but specifying what solution will help us help you. – bmike Mar 24 '13 at 23:03
I want a solution to why the network is not working properly, when it works fine for every non-Mac computer I own... my network appears very stable except when I try and do anything involving the Mac. It is easy to blame OSX but it could be several other things going wrong I think. – Mr. Boy Mar 25 '13 at 20:21

I cannot see how to add the quick answers...

my network appears very stable except when I try and do anything involving the Mac

What other problems are you experiencing?

Have your tried a smaller file.

What is the size of the file you are trying to copy?

Perhaps you could share a windows folder and copy the data that way.


share|improve this answer

My first troubleshooting question is: Have you tried to copy other files from that computer to your computer, and does the file copy process fail in the same way with other files? If not, then the copying problem you are having is only with that one file on the other computer. It may be a corrupted file, in which case the problem is not with the copying process; it is with one corrupted file.

Second, is this something you need to do frequently with many different files, or do you just need this one file? It might indeed be better to spend US$6.00 on a 2GB USB stick, which you can certainly re-use for other purposes later.

Third, are your computers connected to the router via WiFi, or via Ethernet cables? If it is WiFi, can you hook them up with Ethernet cables instead? These kinds of file copy processes usually work better over Ethernet than over WiFi.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.