Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using Parallels on my mac. But when I open a software the font are so small, it's very weird. Can anyone help me out!!!

The tool bar of chrome is so small

The picture above is when I open up my chrome, how can I fix it?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

I've seen this particular problem many times, and a lot of it has to do with how Windows handles DPI scaling.

Since you are using a Retina MBP - which has an extremely high resolution, you'll want Parallels to manage the DPI of your Windows VM. You can do this under your Virtual Machine's configuration, Hardware, Video Options, and select "Best for Retina".

enter image description here

The next time you reboot, Windows will have its DPI set to 199% (why not 200% I'm not sure).

The only trick to this is when you connect to an external display and you want to show your Parallels VM there. Windows can't change it's DPI without a full logout / login - so if you change displays you'll have to log out of Windows and log back in.

The next problem is that Windows does DPI scaling differently - some programs do not respect Windows DPI scaling. It's very bad practices for developers, but some of them always assume a fixed number of points-per-inch, like 96. Windows does its best to fix these issues by bitmap scaling the Window, and translating input, but it won't ever be perfect and it will look like a JPG that's 200% zoomed. It all depends on the program you are using. As unfortunate as it sounds, the best browser on Windows for retina resolution / DPI is Internet Explorer 10.

share|improve this answer
2  
I've found out the problem might be the resolution of Retina that windows don't support. So I've just disabled to let my parallels not to fit my Retina, and it works! But thanks for your reply!!!! It helps me too. –  LiJung Mar 24 '13 at 15:12
    
@LiJung it sounds like you solved the problem you were having, but I was having the same issue (plus a few others) and fixed it by doing the following: apple.stackexchange.com/a/89705/46825 –  recklesscoder May 3 '13 at 23:07
add comment

I had the exact same problem. I went a different route, and decided to sacrifice the nice high-DPI of the Retina for a scaled solution that makes everything look right.

  1. In Parallels VM Config → Hardware → Video → Resolution

    Use: Scaled
    Not: Best for Retina, More Space

  2. Restart VM

  3. Windows Display Settings → Set Resolution: 1280x800 + Apply

  4. Windows Display Settings → "Make text and other items larger or smaller"

    Use: Smaller (100%)

Late-2013 rMBP 13.3″ with Parallels 9.0.23350 and Windows 7

share|improve this answer
add comment

All my coworkers had the same problem. In Parallels 9, you can set for every VM if it should be scaled, best for retina or more space. As DPI scaling under Windows is inherently broken, as application developers have to support this, and many just don't, it's not useful you can configure this at all, which is why more options don't always mean better software (looking at you Parallels). In versions before, Parallels didn't let you choose the wrong things, and didn't have the wrong defaults.

Parallelsmenu -> VM -> Hardware -> Graphics -> resolution -> scaled

You need to open the VM, go to the Virtual Machine menu item in the Macs menu bar, go to Hardware -> Graphics -> and click on scaled, restart your VM, in the Windows VM, go to Start -> Control Panel -> Display Settings -> click the link "Make text and other items larger or smaller" -> set it to 100%

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.