Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to help someone else with their computer, every time I try to access the "Accounts" settings in system preferences, system preferences hangs and then crashes, any idea what's up? The computer is a Macbook 2.4Gz Core Duo, and all the software is up to date.


Edit: This is what comes up in console.

2/18/11 9:25:24 PM  System Preferences[201] NSConcreteMutableAttributedString initWithString:: nil value
2/18/11 9:25:24 PM  System Preferences[201] NSConcreteMutableAttributedString initWithString:: nil value
2/18/11 9:26:37 PM  System Preferences[201] [NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/Accounts.prefPane): should only be called once
share|improve this question
Can you open Console (/Applications/Utilities/Console and post what you see there for System Preferences)? – Nivas Feb 18 '11 at 10:58
up vote 1 down vote accepted

You might get better answers if you provide more information such as when this started happening. For example, did you add a new account recently? Install any applications recently?

Normally, when weird stuff happens on OS X such as crashes, repairing permissions can be a good place to start. Try opening Disk Utility and select your computers Hard Drive on the left hand side, then click 'Repair Permissions'. This will take a few minutes and may solve your problem. Try a restart after the repair before you go back into Accounts.

Have you tried this under a different user account? I've come across instances of people having this only occur on one account. You could create a new account and restore documents etc from a backup.

share|improve this answer
Tried repairing permissions, didn't help. – Ben Feb 19 '11 at 5:49
No problem @Ben, if I can think of anything else which might help I'll update the answer. Some people just down-vote because they can. – conorgriffin Feb 21 '11 at 21:58

It may causes due to corrupt .plist file. Try removing SystemPreference plist file from ~/Library/Preferences/SystemPreference.plist(Close the Sys Pref before doing this). A new file will be created when you start System Preferences again.

share|improve this answer

Are users authenticating with a Directory Server like OpenLDAP or Active Directory? Also, what version of OS X is being used?

share|improve this answer

I had the same problem.

As suggested here, I removed the folder ~/Library/Caches/ and that fixed it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.