Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Mac with a Windows drive that I occasionally boot to. Most of the time, I'm using the Mac, and the Windows disk always mounts and shows up on the desktop. I would like to keep it from showing up or prevent it from mounting at all if possible, without affecting the ability to boot to it when I want to. I found an answer on a blog that uses

$ chflags hidden /Volumes/Time\ Machine/

to hide the volumes. I will do that if there's no way to prevent mounting them. Thanks for any answers!

share|improve this question
    
What about automatically unmounting it as soon as it is mounted? –  zwerdlds Mar 21 '13 at 2:56
    
I use the tip described here: hints.macworld.com/article.php?story=20060930150059172 to stop one of my drives mounting at boot. It still appears in Boot Camp and Disk Utility, but it’s not mounted by default. Is that what you’re looking for? :) –  alexwlchan May 3 '13 at 14:14

1 Answer 1

Create a file /etc/fstab with the following contents.

# fstab
#
# Identifier  mount point  fs type  options1
#
UUID=3CA41C88-3E86-3A39-88CE-9379FF44B6A5 none hfs rw,noauto

The alphabet soup after the = sign can be found with diskutility.

(Fire up DiskUtility, select the disk, right click, More Information Universal ID)

FS tab needs the following ownership and permissions:

bash-3.2# ls -l /etc/fstab
-rw-r--r--  1 root  wheel  71 29 Aug  2011 /etc/fstab

To create the file try this:

sudo nano /etc/fstab

The noauto option causes it to not mount at boot. In a terminal window type man fstab for other options

Not directly applicable to your problem: VirtualBox, VMware, and Parallels can run windows in a virtual machine. VirtualBox allows using a dedicated disk. (Others may, don't know) For applications that are not CPU or graphics intensive, or access the hardware directly this is often good enough. I run MS Access this way. Anything that needs DirectX may have issues or have an unacceptably slow frame rate. Action games don't work well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.