Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Blender requires F-keys such as F12 and numpad. The numpad emulation works for me, but I am unable to get the function keys such as F1, F4 and F12 working. For example, F12 should do rendering. So how can I use Blender with a MacBook?

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

You have two options; either hold down fn as L2G suggested, or switch to the F1 etc. keys to work like that directly.

This can be setup in keyboard preferences here:

enter image description here

If you do that, F1 will work as the actual F1 key. If you want to use it for controlling the brightness, you'd hit fn with it.

share|improve this answer
    
You just need to remove the shortcuts to Fuction keys from the Keyboard Shortcuts menu. Otherwise F12 is not rendering but dashboard. –  hhh Mar 19 '13 at 8:43
add comment

You need to hold down the fn key (lower-left corner) while you're typing one of the F1F12 keys. This is the norm for any app that uses F-keys, not just Blender.

share|improve this answer
1  
This does not work for me. When I press this either with houbysoft's suggestion or not, I get the expose screen with a lot of little apps?! EDIT I got it working after disabling the shortcuts in the settings of the houbysoft, thank you. –  hhh Mar 19 '13 at 8:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.