Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iPhone running ios 6.1.2. I use match frequently, and I notice that from time to time it will completely fill up the space on my iphone. This tends to cause the phone to run very slowly until I delete some items off of the phone. I would like to limit the space of match on my phone so that it will never fill it up. Is this possible?

share|improve this question
up vote 5 down vote accepted

This is not possible. iTunes Match will continue to fill up your storage space as you download tracks locally on the phone through it. I believe it will trim songs once the space is full, to clear off the least-played material.

If you would like, you can manage your storage in a few ways:

  • Go to Settings > General > Usage > Music. Here you can clear all downloaded music.
  • Go to the Music app. Locate downloaded material and swipe across artists, albums or songs to remove them from your local storage.
share|improve this answer
    
I thought this might be the case. Thanks. – derivation Mar 18 '13 at 18:37
    
If you're using Match and running low on disk space, the iPhone will silently delete the least-recently-played music. – Alex Szatmary May 15 '13 at 20:25

It looks like I MAY have finally worked this out. What has fixed it (for now) for me, and doesn't seem to have been mentioned before, is the button for Settings... on iTunes on my Mac, when my iPhone is connected, next to the Autofill button.

Connect your iPhone to your Mac, and click on the icon for the phone. Click on Music on the On My Device menu on the left. Click on Settings... and set the Reserve space for disk use slider right to the right hand side - so that you essentially are saying you're making no space available for music actually ON your device. Click OK.

I did the above, and set off iTunes to prepare a new iCloud Music Library. Once it had done so (24,000 songs), I connected my phone, which was empty of music. On the iPhone, I set the switch for iCloud Music Library ON...it scanned and presented the library, but actually downloaded nothing to my iPhone. It didn't even attempt to.

This has been a real struggle for the last few weeks, but hopefully this has fixed it. I'll let you know if there are any problems down the line...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.