Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is it possible to somehow temporarily disable iMessages on iPhone when using Messages app on Macbook, I don't like my iPhone to vibrate and wake up on the table all the time when someone sends me a message when I'm chatting through Messages app on Macbook?

I notices, that sometimes it vibrates for 1-2 messages and then it stops for the rest of conversation, but now it's showing almost every message on iPhone

share|improve this question
    
I found out of you keep the messages app open, not minimalized - you will get less notification on phone because they are recognized as read by the macbook. –  Rob Mar 18 '13 at 16:30
    
I have Messages app always open, I do not use minimize, just switching to other applications.. but it's still unread until I switch to Messages app.. when I'm actively chatting in Messages, it's not popping out on iPhone (maybe sometimes) –  boobiq Mar 18 '13 at 16:50
add comment

1 Answer 1

The function of iMessage is to push your messages to all devices. To turn this off, go to Settings > Messages and disable iMessage. However, this is certainly not automatic, and may remove your cache of message from your iPhone.

As a commenter mentioned, keeping the app open on the iPhone will minimize your annoyance.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.