Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use iTerm since a few days, and when i press my hotkey, it'll drop down nicely, from top of the screen, but ... on the wrong one.

I have a macbook pro with mountain lion, and i connect it to a 24" screen for development. It would be awesome if it can dropdown on the big screen if it is connected.

This might be a more general thing, since any menu bar of any app is showing on the small screen, instead of the external.

(ps. I use both screens, not in mirror mode obviously)

Any ways around this?

share|improve this question
    
Crikey, i missed this all the time. But it's in preferences -> display -> drag the menu bar to other screen. I never realized (or cared to read the xplanation text) that you could drag that menu bar. –  Marten Sytema Mar 18 '13 at 13:38
    
write that up as an answer –  Mark Mar 18 '13 at 15:19
    
thanks for the reminder, done –  Marten Sytema Oct 3 '13 at 14:00
add comment

2 Answers 2

up vote 1 down vote accepted

Crikey, I missed this all the time. But it's in preferences -> display -> drag the menu bar to other screen. I never realized (or cared to read the explanation text) that you could drag that menu bar.

share|improve this answer
add comment

iTerm2 Build 1.0.0.20130319:

Iterm->Preferences->Profiles->Window

From there you have a screen bar you can set to 'screen2' or 'main screen'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.