Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In my keyboard when I pressed this key

enter image description here

Then I get/display '§' (with shift+key -> '±' ) instead of what expected.

How can I set it to work properly?

Also after Googling I found this site but this did not help me.

share|improve this question
    
In the Input Sources tab of system prefs/language & text, make sure the box for British is not checked and only the box for US is checked. Does this change things? –  Tom Gewecke Mar 13 '13 at 13:11
    
That's the exact button as programmed for a mac keyboard. You might find settings in your keyboard preferences to change this manually. –  Rob Mar 13 '13 at 13:29
    
@TomGewecke- yup...i checked it...US is Checked..:) –  iPatel Mar 13 '13 at 13:55
    
Thanks, that is helpful (assuming British is NOT also checked), and I modified my answer slightly. –  Tom Gewecke Mar 13 '13 at 14:52

1 Answer 1

My guess is that your machine thinks the keyboard "type" is English (International) ISO, when it is really English (USA) ANSI. This article may help:

http://m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.