Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just started using a MacBook Pro in addition to my Windows 7 laptop (to see if the OS X 10.8 will be a good alternative for me). At Windows bootup, since my user is the only one on the computer, it is already selected at the login screen and I just type my password and go.

On OS X 10.8.2 it shows my name and a Guest account. I have to select my name with the mouse before I can type in my password. I can't even use the keyboard to tab over to my name:

picture showing login screen

How can I disable the Guest account from showing on the login screen so only my user is displayed with a password box?

In Users & Groups the Guest user is disabled:

screenshot of Guest account disabled

I also did some searching and found that this could be a side affect of the 'Find my Mac' feature of iCloud. I verified it is also disabled:

screenshot showing iCloud find my mac disabled

Any ideas?

share|improve this question
1  
Have you tried signing out of iCloud and restart? –  David Pearce Mar 11 '13 at 16:20
1  
Yes, I tried that and there is no change. –  Andy Shinn Mar 11 '13 at 17:16
    
I don't have a guest option but have gone through this process - osxdaily.com/2011/06/30/… –  bassplayer7 Mar 11 '13 at 18:46
    
Don't forget this if you do wipe the recovery partition: support.apple.com/kb/DL1433 –  bassplayer7 Mar 11 '13 at 18:51
    
I don't have a recovery partition so I don't think this is relevant: Andys-MacBook:puppet-zabbix ashinn$ diskutil list /dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *500.3 GB disk0 1: EFI 209.7 MB disk0s1 2: Apple_HFS Samsung SSD 499.9 GB disk0s2 –  Andy Shinn Mar 11 '13 at 22:27

3 Answers 3

up vote 11 down vote accepted

@andyshinn OK, I see on your screen shot, that is not Guest user icon, that is Group user!

It says Other (not Guest).

The Guest user shows with one face, the group shows with multiple faces, like your icon.

I see you are at work. Do you have a group user account set up by your IT people?

Let me clarify that. Someone or something (a program) has put a login and hidden it from you so you can not delete it.

Well you can now do something since you know about it. First lets find out who! then decide if you want to delete it.

share|improve this answer
1  
This actually makes sense. –  Andy Shinn Mar 14 '13 at 15:46
3  
This turned out to be correct. I didn't realize "Other" and "Guest" were separate (I just assumed enabling Guest meant the Other option showed up to enter Guest credentials). The ultimate reason for the "Other" option turned out to be a group that was added by some software (Puppet) that I am working with. I installed it locally and it had installed a puppet user and puppet group. After uninstalling the software and removing the users, the login screen now shows only my user with the password box. Thanks! –  Andy Shinn Mar 14 '13 at 15:50
    
You are welcome! I could only do that since you took the time to get a photograph of your display. I took me a while to look closer and to be honest I was distracted by the Rubber Ducky on the top left of the display :) –  user44516 Mar 15 '13 at 14:56

I was able to confirm this being tied to "Find My Mac" being enabled by toggling the option while setting up a new Mac, however I'm unable to revert back to the previous state where the only options are normal user accounts. I've disabled "Find My Mac", signed out of iCloud, rebooted, removed com.apple.loginwindow.plist from /Library all with no change.

What I CAN tell you is that you can login without needing to use the trackpad/mouse:

  • At the login window you can use the right or left arrow keys to select a user
  • Click return to select the user
  • Enter your password and click return again to log in
share|improve this answer
3  
Ah, I didn't think of using the arrow keys. This helps. But doesn't seem like the ultimate solution. If I can't find a real fix in a week or so, I will accept this as an answer which should gain you some rep so you can add comments in the future :) –  Andy Shinn Mar 11 '13 at 17:18
    
I totally get that. Once I have some free time at work (Ha!) I'll see if I can figure it out, if nothing else because it's an odd bug. –  Mr Rabbit Mar 11 '13 at 18:57

Possible solution:

How to disable the root user (your "Other" login account) OS X Lion

From the Apple menu choose System Preferences.... From the View menu choose Users & Groups. Click on the lock and authenticate with an administrator account. Click Login Options.... Click the "Edit..." or "Join..." button at the bottom right Click the "Open Directory Utility..." button. Click the lock in the Directory Utility window. Enter an administrator account name and password, then click OK. Choose Disable Root User from the Edit menu.

Just in case you are wondering: You are NOT the root user.

About the root user

The user named "root" is a special user in UNIX-style operating systems that has read and write privileges to all areas of the file system. The root user should only be used for specific administration or monitoring tasks. After completing a task as the root user, you should log out of Mac OS X (this is what your IT forgot to do) and log back in using a normal or administrator account. You should disable root access if you do not use it often.

The root user does not appear in Users or Accounts preferences.

share|improve this answer
    
The root user account was already disabled. –  Andy Shinn Mar 14 '13 at 15:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.