Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

We have one canon copier machine which is connected to our LAN router via Ethernet cable. Currently, we are connecting to the Internet using a different router. To work with the printer, I need to manually configure the Ethernet connection as follows.

Ip Address: 192.168.1.19
Subnetmask: 255.255.255.0
Router: 192.168.1.1

When set with the above settings and connected to both the Ethernet network and the Airport (Internet) network, I can print, but I cannot browse the Internet anymore. Could this be caused by an ip conflict ?

I can setup like this in windows and can use both printer and Internet at the same time. Should I use the same router for both Internet and LAN connections? Is there any way to solve this?

share|improve this question
    
Yes - you will want to set up the second router in bridge mode or consolidate for the most natural / simple network where everything works together. –  bmike Jul 9 '11 at 18:23
    
Also - if you look at your routing table in network utility, you will see of the ip ranges conflict. Post them if you are not sure and someone here can maybe offer advice. –  bmike Jul 12 '11 at 20:20
add comment

4 Answers

I'm guessing here, but it your network settings may have the ethernet interface prioritized above the AirPort (this is the default setting), meaning that when both are connected it'll try to reach the internet through the ethernet connection. You can check this easily be looking at the order the network "services" are listed in the sidebar of the Network system preference pane. If Ethernet is prioritized above AirPort, change it by selecting Set Service Order from the action (gear) pop-up menu below the service list, then dragging AirPort above Ethernet. Note that you need to click the Apply button for the change to take effect.

share|improve this answer
add comment

I suspect the issue might be that your routers probably have the same IP address on both networks. So if your printer router and your internet router both have an IP address of 192.168.1.1 then your Mac may not know which interface to choose for traffic to that network. So it will probably pick the network which is listed first on the list in System Preferences > Network.

You could try reconfiguring the printer router to have an IP address of 192.168.2.1 and setting it to use DHCP with a subnet mask of 255.255.255.0. Then your Mac could have an IP address of 192.168.2.19 and it would know that traffic for the printer should go out on the wired connection.

Just as a note, you can change the order your Mac selects networks by clicking the gear wheel button beneath the interface list and choosing 'Set Service Order' but I don't think that's going to help you in this case.

share|improve this answer
    
thanks i will try –  knightrider Feb 16 '11 at 9:49
add comment

The ideal solution is indeed to simplify your home network by only having a single router (likely the existing Airport router). Using a single router and it's DHCP server will assure that all of your home devices are assigned IP addresses that are within the same IP subnet and can therefore all communicate with one another.

You could consider replacing the second router near the Canon copier with a WiFi-to-Ethernet bridge to provide available wired Ethernet ports but simply bridge them to the existing Airport network. A bridge keeps all the devices on the same IP subnet (unlike a router in it's default configuration). If the router near the copier also has wireless capabilities you may be able to configure it as a bridge instead of a router by looking through it's web configuration screen.

Once all of your wired and wireless devices are on the same IP subnet and using the same router (default gateway) then they will all be able to both see each other on the network and also get to the Internet.

share|improve this answer
add comment

Got the Network preferences pane in System preferences. Drag Airport to the top of the list.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.