Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently bought a new iPhone 5. When I was going through my contacts today, I noticed a lot of email adresses stored along with the other numbers. I didn't even know most of them! What has happened?

share|improve this question

4 Answers 4

This is likely because iOS 6 has Facebook and Twitter contact import. So, if you logged into your Facebook account on your iPhone, it will automatically go through your contacts and pull in information that it finds in their Facebook account.

share|improve this answer
    
Ok...but what about those people's email addresses who are not even my friends on Facebook and Twitter? –  Vanshekaa Mar 9 '13 at 19:24
    
Did you add an Exchange account? –  Rob Mar 9 '13 at 20:13
    
This is an iCloud sync problem. It's happened to me many times in recent years - even before iCloud. It's not related to just the Facebook and Twitter integration. –  Kirk McElhearn Mar 10 '13 at 8:53

It may be a longshot, but in addition to the Twitter/Facebook contact import mentioned above, are you perchance using Gmail, and syncing iOS to your Google Contacts via CardDAV?

If so, you're probably seeing Google's 'My Contacts' in your address book. For every person who sends you an email, Google keeps a record of them in your Google Contacts. The unfortunate side effect is, if you ever sync your Google Contacts to another contact list (such as your iPhone address book), it winds up passing all of those one-time contacts into your address book by default.

Equally as unfortunate is that there's no good way to prevent it, aside from not syncing your Google Contacts with your iPhone.

share|improve this answer

If you use Mail for OS X, and you sync contacts with iCloud, it is possible you accidentally added contacts by selecting several Mail messages and pressing Cmd-Shift-Y (the action for "Add to Contacts" instead of Cmd-Shift-U (the action for "Mark as Unread/Read"). Since these commands are one key apart, and there is no user confirmation required for the "Add to Contacts" action, users can perform this action by mistake without realizing it. If that is what happened to you, you would unfortunately need to go through your contacts one by one to eliminate unwanted information.

To prevent this from happening again, you can change the keyboard shortcut for the "Add Sender to Address Book" and "Add Senders to Address Book" menu items in Mail for OS X with the System Preferences application. Here are steps to do that. I am referencing Lion, so the menu item names or the keyboard commands may already be different in Mountain Lion.

  1. Open the System Preferences application
  2. Choose the Keyboard icon to view Keyboard preferences
  3. Choose the Keyboard Shortcuts tab
  4. Press the + button below the list of shortcuts
  5. In the Application popup, choose Mail
  6. For the Menu Title, enter "Add Sender to Address Book" (without quotes)
  7. Tab to, or click in, the Keyboard Shortcut box, and type Ctrl-Opt-Shift-Cmd-Y
  8. Press the Add button to save the new shortcut
  9. Repeat the process and use "Add Senders to Address Book" (without quotes), the plural form of the menu title, for step 6.
share|improve this answer

Also, if you check to see your mail account setting on the phone that may be enabled. We have seen where exchange mail account is adding random emails in our employees phones.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.