Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Within the iMessages app on OS X 10.8.2 all of my iMessage conversations have switched to Bonjour. So instead of showing the usual blue bubble it's red and people's phone numbers are shown instead of their contact name.

If I go to an individual conversation and click on the down arrow I have the option to change the messaging service from Bonjour to iMessage.

iMessage-Bonjour example

If I click iMessage the phone number is replaced with the contact name and photo from my contacts, but any previous conversation is gone. If the person then subsequently sends me a message the conversation history comes back.

This method does not work for group chats. If I click on a group chat that includes the same phone number I do not get the iMessage option.

  • Is there a way to mass change all of my iMessage conversations from Bonjour back to iMessage so I don't have to do it one-by-one?
  • Is there any way to change the group chat back to iMessage?
  • Is there a way to recover conversation history without waiting for a contact to send me a new message?

iMessage group chat screenshot

This happened after I took my Mac to the Genius bar to get some hardware fixed. When I got it back everything was fine except for iMessage being messed up as described above.

Update: There's a similar question on the Apples Support boards, but the solution did not work for me: com.apple.ichat.Subnet.plist did not exist.

share|improve this question

2 Answers 2

Under the messaged drop down menu, go to accounts and then uncheck bonjour. Your iMessages and/or your iTunes account should be selected.

share|improve this answer
    
iMessage was already selected. No dice. –  Adam Wuerl Oct 2 '13 at 4:21
    
@AdamWuerl once you uncheck bonjour, what happens if you then send a new message from a window marked bonjour? It should revert to another delivery and clear the red last message status with the correct last transport class. –  bmike Dec 8 '13 at 13:55
    
I can't find out anymore, because after the update to Mavericks the problem seemed to have fixed itself and I no longer see Bonjour as an option and the past conversations are showing up as expected. –  Adam Wuerl Dec 14 '13 at 22:18

In addition to unselecting Bonjour, which I agree was insufficient, I found that under Messages > Preferences, my Apple ID had been deselected. Once I re-selected it, I could then identify the phone numbers and email addresses I wanted to use with messaging.

I suspect my original cause was my daughter's wanting me to turn off messaging for her email address (she is young and so her stuff is under my Apple ID) and somehow that turned off the MacBook's messaging entirely, not just her address. Curiously, my iPhone was affected.

I also suspect I selected Bonjour in a futile attempt to fix messaging on the MacBook. Hope this is helpful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.