Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When searching for mail in Mail.app with a GMail account, every instance of the mail shows up with every Gmail label, especially in the Bin label, since Apple mail autosaves drafts as you go along, there can be 50 instances of a single mail just in the Bin folder.

This makes searching impossible.

So I'm trying to turn off those labels in Gmail but no success so far. I have disabled "Show in IMAP" option in the GMail label settings for all those labels then deleted all the cached items in ~/Library/Mail/V2 and restarted Mail.app but that didn't do the trick.

share|improve this question
add comment

2 Answers 2

I'm going to suggest that you use this tutorial to make GMail and Mail.app work together. The key for me was disabling the "All Mail" label, which was causing havoc in my mail setup.

LINK

share|improve this answer
add comment

Those folders are for your convenience, can be deleted in Mail -- or under the Mailbox menu, you can choose "Use this folder for" ...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.