Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I"m trying to connect to my linux server which uses public key authentication. By default, the .ssh folder is hidden on my mac (which I can access via the terminal). However, when I try to setup a connection using either Cyberduck or Transmit, the Finder popup that opens does not show the .ssh folder.

How do I select the key ?

One alternative would be to copy the key to a directory outside the .ssh folder. But i'd definitely like to hear other solutions. How are you doing it ?

share|improve this question
    
Transmit will honor your .ssh/config, and if you have a .ssh/id_rsa, it'll use that automatically. Just connect like you normally would, but leave the password blank. –  Warren Pena Mar 8 '13 at 17:28
add comment

3 Answers 3

up vote 4 down vote accepted

In the find file window, press Command-Shift-G. It'll ask you what folder to navigate to. Enter "~/.ssh" and press return.

share|improve this answer
    
Yes ! Worked !! –  WarDoGG Mar 10 '13 at 15:52
add comment

You need to tell Transmit or Cyberduck to show your hidden folders. The . in the folder name is part of why it is hidden.

In Transmit, there should be a menu option in View -> Show Invisible Files. Cyberduck may have a similar menu option in the View menu, but it may say Show Hidden Files.

This will let you see it in the application. If you need to see it in an Open file dialog, press cmd + Shift + G` while the open dialog window is open. This will drop down a "Go to the folder" screen. Type in the hidden folder path you wish to navigate to and that folder will now display in the open dialog window.

share|improve this answer
add comment

Open the Terminal window on your MAC:( by default you will be in Home dir.)

type : $ ls -la

This will list all the files & folder including hidden folders.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.