Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In my job, I have a number of "always-open" web applications that are part of my desktop layout. I always have Trello open, plus two different Stack Exchange Chat rooms. I also have another browser window that I use like everyone else, navigating to various sites in tabs, etc.

Because I always want to keep trello and chat open, and I never want to open links from those sites in those windows, Fluid is a near perfect solution, as it creates a native, OSX app for each window. I click it, and it opens that site as a stand-alone app, which I can set to open all links in my "normal" browser, etc. I LOVE IT, and was going to switch to the paid version and get my small team on it. (I have no affiliation, just a genuine fan).

But I've encountered an issue:

At seemingly random times, typing text in a text entry box causes the cursor to leave the box and the window to scroll back up most of the way to the top of the window.

I've tested this quite a bit, and know this:

  • I'm not accidentally hitting Control, Alt, etc. The only modifier key I'm using is Shift.
  • I can't seem to repro it even when using the same text in the same instance it happened. After occurrences, I literally moved focus back to the box where it happened, deleted the text I was typing when it happened, and re-typed it, but it didn't occur.
  • It never seems to happen when I'm not typing text in the box, so I'm pretty sure the issue is linked to that activity.
  • This has always happened to me in a Stack Exchange Chat window, but I don't use Fluid for any other "text-entry" sites, so that may not be relevant. (It's not a problem for SE chat in normal browsers; I've logged thousands of hours doing the same thing in chrome and safari without incident).

Since each fluid instance is essentially an app, I thought there might be some hotkey setting somewhere I had set wrong, but can't find anything of the sort in the app or from online searches.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I have had this too. It is caused due the live spell checking service responding late while you are typing.

Apparently, while replacing a mistyped word, the service takes focus of the text box. Usually, this happens so quickly that you don't notice it. But sometimes, the service takes too much time (relatively) to process a word while you are still typing. And if you press Spacebar* when this happens, the page moves up/down.

When this first happened, I thought it was totally dependent on the performance of your computer and there was no specific way to solve it.

Safe Reboot - try this first:

One day, I accidentally activated Safe Boot. For me, this stopped the problem from happening, even after I rebooted normally. Aside from its normal uses, Safe Boot also clears out caches, repairs permissions, and performs other maintenance tasks. That is why you see a progress bar on a Safe Boot. But that method doesn't work for everyone.

Turn off AutoCorrect - here's a solution that should work if that doesn't solve it:

This solution requires you to turn off auto-correct for the app. You can still keep spell-check on, so it will still highlight misspellings; it just won't automatically change them.

  1. Go to the affected app.
  2. Click in the box where you're having trouble when you enter text, to put the cursor there.
  3. In the menu bar, select Edit > Spelling and Grammar > Uncheck Correct spelling automatically. You can leave Check spelling when typing checked, so it will continue to show you misspellings as you type.

* Pressing the Spacebar when a text box isn't in focus sends a scroll down action to the current page. And pressing Shift + Spacebar sends a scroll up.

share|improve this answer
    
+1 Can you add a little more color on the "safe boot" solution? Will it just clean out some things, and then I won't have the problem for a while, but all else will be the same, or will it do something ongoing (like disable spellcheck, etc.) –  Jaydles Mar 7 '13 at 16:39
    
Safe Boot just performs some maintenance. It won't disable spell check. Read more about safe boot here support.apple.com/kb/HT1564?viewlocale=en_US&locale=en_US –  duci9y Mar 7 '13 at 16:42
    
Last question (I think): Does the safe boot clean out things that will make it work even after I reboot again normally? I'm pretty sure I can't leave it permanently in safe boot mode because it disables audio hardware in/out, and I need to use a headset a lot. –  Jaydles Mar 7 '13 at 16:48
    
Safe boot is run once and forget. It only boots in safe mode when you hold down shift at boot. Safe boot won't affect functionality of your computer at all, just performance. –  duci9y Mar 7 '13 at 17:26
    
Thanks for the suggestion, but issue still occurs after safe booting, then re-booting. –  Jaydles Mar 7 '13 at 22:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.