Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to set up my POP3 Gmail account on a Retina MBP running OS X 10.8.2. A few months ago, I managed to do the same thing, the first time around, on an iMac, working with the same Gmail account and under an earlier Mountain Lion release.

This time, Mail gives me no errors, and despite having followed Google's guidelines on how to set up POP3 email on Apple Mail, no messages will download on the MBP, even after checking for new mail, and right-clicking the account to force download. Has anyone encountered this issue, and found a fix?

share|improve this question
1  
Why don't you use IMAP? –  duci9y Mar 5 '13 at 7:18
    
I don't think IMAP allows for GPG encryption. –  Jules Mazur Mar 5 '13 at 13:36
add comment

3 Answers

Review your settings on the Gmail website; could you have perhaps overlooked the checkbox to Download all messages from today on (or whatever your preference is)?

By the way, I have my Mail.app accounts all set to POP3, and iDevices, of course, are on IMAP ... so that works; on the GMail page, you can leave them both on.

Check your Mail.app account preferences: in Advanced, the port needs to be set to 995. And have you run Mail's Connection Doctor, under the Window menu? When it can't connect, clicking on the error will take you right to the place in Mail preferences where the error is.

share|improve this answer
    
The port is 995, and the connection doctor shows green lights across the board. I deleted the account, and added it again following Google's instruction to the letter. The loading bar shows all 17K+ letters being downloaded, but none of them show up in my inbox. –  Jules Mazur Mar 5 '13 at 14:17
add comment

Whoa. Is that mail on your machine--Probably. Is your ~/Library folder visible? Look in ~/Library/Mail.V2. It should contain folders named Mailbox, MaiData, and one for each of your email addresses, whether POP or IMAP.

FINDING your mail: Okay, here's the odd part, but it could be the problem. I use POP3 GMail, and the account folders read as follows: POP-xxx@gmail.com@pop.gmail.com. They created themselves, and when I fooled with their naming, the gorilla wasn't happy. Leaving them be, everything works fine.

IMPORTING your own mail: Whether or not you have these oddly named folders, if you find--open V2 in list view and calculate all sizes--that there's 17 (MB?) of mail in there, the quickest way to get up and running is to select Import Mailboxes, navigate to within the account folder to choose one mailbox at a time, and once imported, use Select All and Move the messages to the right Mailbox in the sidebar.

Quit Mail, open it again, and see if your mail doesn't show up.

share|improve this answer
add comment
up vote 0 down vote accepted

The solution turned out to be, removing the mail account, disabling IMAP in Gmail's settings, restarting my machine, and adding the account again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.