Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just recently bought an album on iTunes and I have a weird problem. All of the songs (18 in all) except for one, play perfectly fine. When I try to play it, it says "This computer is not authorized to play "". Would you like to authorize it?" It prompts me to sign in with my Apple ID, which I did. Then it says "This computer is already authorized." I have no clue how to fix this! I've tried the steps outlined in iTunes: Missing folder or incorrect permissions may prevent authorization and iTunes repeatedly prompts to authorize computer to play iTunes Store purchases, but neither of them work. Any suggestions?

share|improve this question
Still happens in latest version on iTunes; my content is deauthorized at random and I have to find the song, delete it and re-purchase from the iTunes store. – lonstar Aug 16 '15 at 15:29
up vote 1 down vote accepted

In the end, deleting all the offending track and re-downloading it was the only thing that worked. Why I didn't think about this at first, I don't know, but it worked!

share|improve this answer

Maybe you could try uninstall the iTunes and then download and install the latest version, authorize again.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

I could, but then I lose my library... – daviesgeek Mar 4 '13 at 17:17
@daviesgeek Uninstalling iTunes would neither delete the media files nor the library's data files. – HairOfTheDog Mar 4 '13 at 17:21
Ok, maybe I'll try that then! – daviesgeek Mar 4 '13 at 20:46

I would recommend deauthorizing all your computers from iTunes. Go to the iTunes Store, and look for the Account link under Quick Links on the home page. Under Apple ID Summary, look for Computer Authorizations, then click on Deauthorize All. You'll need to reauthorize all the computers that use your account; though you may just have the one.

share|improve this answer
Okay. I'd much rather do that than what Jolya suggested. Thanks – daviesgeek Mar 6 '13 at 18:13
I found the "Computer Authorizations", but there's no "Deauthorize All" button... – daviesgeek Mar 7 '13 at 0:15

The "deauthorize all" option will only show up if you have more than one computer authorized on your account. If you have only one computer authorized it can be deauthorized right from the "Store" menu. I had the exact same problem - what worked for me was to make sure the "iCloud download" column was checked and visible (right click in area where artist, name etc labels are and scroll down to click on "iCloud download"), a small icon with a cloud and an arrow were shown beside my song and clicking on that downloaded it from the cloud. I can play it now. I'm not sure why the file went to the cloud at all when I downloaded it - my computer is not connected in any way but I will have to further investigate that. I hope this helps!

share|improve this answer

What worked for me was in iTunes, top right corner on click on down arrow, and then Account info, then manage devices in iCloud. This was very different from the authorised computers under STORE in itunes. Once I deauthorised all, I could then authorise my computer. Big thumbs up to Apple support for that solution, will try to get them to update their support pages with that fix.

share|improve this answer

JUST found the solution to my nearly year long battle with iTunes and the: You are not authorized. You're already authorized issue. Just adding this to spread the word that Ctrl +b -> Edit -> Preferences -> Advanced -> Reset Cache worked for me.

Every time iTunes started it thought it was freshly installed and prompted me to go through the tour, set the default music player, and authorize (each time saying it was already authorized). It wasn't just one song, it was about 50% of my music and 100% of my movies. I had already tried- deauthorizing then authorizing, uninstalling, reinstalling, deleting that SC- folder and restarting -- nothing worked until I cleared the cache.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.