Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My workplace has VPN and it works great for me in Parallels Windows XP and Bootcamp Windows Vista. However, with the same config, I can't get it to work in Snow Leopard. I don't know what type of server they are using, but PPTP works for Windows. Any ideas why it may work for Windows and not OS X?

Update: I should also mention that at one point it did work. I couldn't tell you if anything changed at the server between when it did work and when it stopped.

More information: I can connect just fine, but I can't access any resources. I try to ping a known internal IP address and the destination can't be reached.

share|improve this question
1  
did you check on "send all traffic over VPN"? –  Am1rr3zA Feb 14 '11 at 20:45
    
@Am1rr3zA Yes, I have tried both ways, but I know that I have to send all traffic for the work VPN. I know because I played with that in Windows. –  Mike Wills Feb 14 '11 at 21:59
1  
What exactly is failing (i.e. does it get a connection error, or connect but not pass traffic)? Also, what does the PPP log show when you try to connect? –  Gordon Davisson Feb 16 '11 at 16:41
    
@Gordon I'll look then report on it tonight. –  Mike Wills Feb 16 '11 at 20:44
    
Now it works. I know I switched back and forth on the route all traffic, but now it works. Thanks for the help. –  Mike Wills Feb 24 '11 at 1:36

3 Answers 3

up vote 0 down vote accepted

@Am1rr3zA Had the answer in this case, though I have tried this in the past and have had it fail.

share|improve this answer

I've had trouble with VPN before on my setup. I fixed my problem, but I had to do a couple of weird things first. Could you tell me more about your settings?

Under System > Preferences > Advanced...

  1. Under (tab) DNS > DNS Servers: Do you have your DNS servers set?

    a. If so, are they something like 192.168.0.2 and 192.168.0.4? You may need to change your home router's IP address if so.

  2. Under (tab) DNS > Search Domains: do you have a search domain set? ie. domain.local

I hope changing those settings helps. If not let me know and I'll try to help. VPN has been enormously frustrating for me in the past.

share|improve this answer
    
I was going to suggest the same thing. Change your home router's base IP to something like 192.168.2.xxx -- everyone seems to be using 192.168.0.xxx these days and conflicts abound. Had the exact same problem with my home network and a client's VPN'ed network a few months back. –  Ian C. Feb 15 '11 at 14:45

In my experience, this is usually due to authentication or encryption. Double-check your settings. Also I wonder if the server may be on an encryption scheme unsupported by OS X.

share|improve this answer
    
That could be. At which point I assume I am screwed. –  Mike Wills Feb 15 '11 at 14:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.