Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This is about the standalone Messenger, not the main Facebook app.

Is there any way to disable vibration when receiving a message? Even if I'm already viewing the conversation it vibrates every time a message comes in. The main Facebook app doesn't so this, only the standalone Messenger.

The only way I've found to stop it is to turn off push notifications entirely, which I don't want to do.

share|improve this question
add comment

2 Answers 2

You can change vibration settings by opening the Settings.app and selecting the "Sounds" option. The two first options are "Vibrate on Ring" and "Vibrate on Silent". Turn these off to disable all vibrations. However, this will disable vibrations system wide for all apps, not just Messages.

To get as close as possible to disabling vibrations for just the messages app:

  1. Open Settings.app and navigate to "Sounds" -> "Text Tone".
  2. Scroll to the top of the page and select "Vibration"
  3. Scroll to bottom of page (under "Custom") and select "Create New Vibration".

    Note: you can't create 0 vibration as you have to tap to start the "recording". However, you can tap it very lightly to start the "recording".

  4. Tap the screen very lightly and let the recording go until it stops. Like I mentioned, it is perfect, but very close - especially if you tap very lightly.

  5. Save the Recording (something like "Minimal Vibe") and assign that to you text tone vibration pattern.

Keep in mind, it is possible to override that vibration pattern when you set custom ringtones or vibration patterns on individual contacts, so if it isn't working quite right for you for certain contacts, be sure to check those settings. Or, the alternative would be to set the "Minimal Vibe" settings for just some particular contacts.

share|improve this answer
    
Thanks, but I don't want to turn off the vibrate feature system-wide. –  ERJ Sep 20 '13 at 1:51
add comment

I solved this :)

  • Settings App
  • Notice Center
  • Scroll down to Facebook
  • Remove the "Sound" Checkbox

Wolla, no sound nor vibration.

Good luck!

share|improve this answer
    
Not the notification vibrate. The vibration caused when you mute the phone and have the app open to that conversation (no notifications) –  ERJ Sep 20 '13 at 1:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.