Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I can't get Spotlight to search for any documents.

When I search the Finder for documents, nothing happens and the Spotlight search through the menu bar only shows up web searches.

share|improve this question
    
onyx solved the prob –  polyglot Mar 1 '13 at 21:22
5  
Please post your answer as a real answer below, using the "Answer your question" button. Thanks! –  slhck Mar 1 '13 at 21:38

3 Answers 3

Firsts, make sure you have enough free disk space. How much is enough? Well, if you have 10% of the drive free, it should do.

Open Terminal and execute the following commands one after another:

sudo mdutil -i off /
sudo mdutil -E /
sudo mdutil -i on /

Now Spotline should start indexing your drive. This may take hours but you should get search back after it ends.

Before or after you do that, you can check Spotlight status in Terminal using:

sudo mdutil -sv /
share|improve this answer

Go to System Preferences. Click on Spotlight. Click on Privacy tab. Click "+" to add a privacy location. Select "Macintosh HD" (or whatever you have named your hard drive).

Wait a few minutes and enter System Preferences again. Go to the Spotlight Privacy tab. Select "Macintosh HD" from the privacy list and remove it.

This is a simple way to force Spotlight to re-index your system.

share|improve this answer
    
Doesn't work on LION 10.8.2. Spot light won't allow me to add my HD to the privacy list. Says I don't have the permissions to do so. So, is there another solution? Or is is different for LION 10.8.2. Anyone else have any solutions? –  user45665 Mar 21 '13 at 1:34
    
@user45665 you will need to be a local administrator of your computer to do this. If you are then you may have permissions issues with your disk, which you can use Disk Utility to fix. –  bispymusic Mar 21 '13 at 14:08
    
@user45665, also just FYI... Lion is 10.7.x and Mountain Lion is 10.8.x. If you have 10.8.2 then you have Mountain Lion. My fix above works going back to (I believe) 10.4.x –  bispymusic Mar 21 '13 at 14:09

Try clicking on All My Files in your finder window. Then wait till it lists all your files then go and try a search.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.