Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am acually running Mac OSX 10.8.2 on a 2.5GHz Intel Core i5 @ 4 Go (1600 MHz) DDR3.

I am using Apple Message apps for synchronizing my SMS with my computer. The problem is that everytime my computer come back from a sleep, I have a memory leak in Message and I need to quit the process in the Activity Monitor because It's freeze my computer.

As you see, on the screenshot, Message use 1.45 GB and will continue to grow up if I don't quit the process.

I haven't found anything about this memory leak, and I would like to know If someone know how to fix the problem. When I Quit Message, I can reopen it and it works without any problem.

Apple Message (not responding)

share|improve this question
    
That use-case leverages the iMessage API, which is currently proprietary, no 3rd party apps will work. Deleted useless comment. –  Barry Mar 5 '13 at 18:56
    
As usual: do the logs say something relevant upon waking up? You can find them using Console.app –  Agos Mar 5 '13 at 22:40
    
@Agos I have a lot of logs for Messages in Console.app. The logs are really big (I can't show logs on pastebin, too big).. Is there a particular line I should looking for? –  Pier-Alexandre Bouchard Mar 6 '13 at 5:34
    
@Pier-AlexandreBouchard I'd look flor errors, anything telling something has gone wrong. Look for date/times after you wake up: it should restrict the search a lot. –  Agos Mar 6 '13 at 8:33
1  
Have you tried disabling different account types in Messages to isolate what is causing the problem? E.g. turning of AIM or Google Talk accounts and seeing if the problem stops when they're disabled? One sure way to fix this would be to switch to something like Adium (if you're not using Messages for the iMessage functionality). –  glenstorey Mar 7 '13 at 2:53

2 Answers 2

I would file a ticket with Apple. It needs to be addressed, and Apple is very good about following up.

http://www.apple.com/feedback/macosx.html

share|improve this answer
2  
Well, Barry, It doesn't really answer my question.. –  Pier-Alexandre Bouchard Mar 5 '13 at 20:17
    
That is the way to get an answer because there is no answer apart from Apple. Keep searching. –  Barry Mar 5 '13 at 20:25
1  
I already send a ticket to Apple. Here, I am looking for a concrete solution. This is the reason of the bounty.. –  Pier-Alexandre Bouchard Mar 5 '13 at 21:27
3  
This is a bug. There is no concrete fix, other than convincing Apple's development team to fix it. You can also call AppleCare and see if they will open an Espresso ticket for it, filing it as a bug. –  bispymusic Mar 8 '13 at 21:18
1  
Apple rarely acknowledges their bugs publicly, especially ones that are not widespread. Check out this thread on Apple's Discussion Boards: discussions.apple.com/thread/4360412 –  bispymusic Mar 9 '13 at 18:54

Here's what I would do to actually try and fix the problem. We will completely reset iMessage.

First up, log out of all accounts from Messages and Facetime, and then close them down. Create two folders on your Desktop: Messages, and Preferences.

With Finder as the active application, hit shift ⌘ cmd G and enter in ~/Library/Messages/. Drag the contents of this folder into the Messages folder your created on your desktop. Basically, you want to remove everything from the ~/Library/Messages/ folder and back it up on your desktop just in case.

Then, hit shift ⌘ cmd G again and enter ~/Library/Preferences/. Look for any files starting with:

  • com.apple.imservice
  • com.apple.imagent
  • com.apple.iChat

and drag them into the Preferences folder on your Desktop.

Now, restart your Mac, log back into iMessage and see if the issue persists.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.