Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a late 2012 Mac Mini with Mountain Lion installed. I have had the Mini for around 6 weeks and am using as a media server.

When the Mini goes to sleep (either automatically or by manually telling it to) it refuses to wake up. The power light is pulsing.

The Mini is connected via HDMI to a home cinema receiver (which is in turn connected to a TV) and has an external USB hard disc and USB hub attached. There is a wireless keyboard and mouse attached via USB also.

In the Energy Saving preferences I have all tick boxes enabled apart from "put hard discs to sleep". I have tried the wireless keyboard, mouse and the Apple Remote app to wake the Mini to no avail.

Any ideas? I really need it to sleep and wake when needed as thats an essential feature of a media server.

share|improve this question
    
I had the reverse (wouldn't go to sleep), in your case has that always happened? have you done the usual tricks (repair permissions, reset PRAM, check memory, etc?) –  jackJoe Feb 27 '13 at 11:30
    
I think it has always happened. I was only concerned with sleeping it once Home Sharing was enabled. I haven't reset PRAM or anything else - I was under the impression that is only required if you have upgraded the OS, which I haven't –  rf_wilson Feb 27 '13 at 11:50
    
Are you running OS X 10.8.2 by any chance? –  MrDaniel Feb 27 '13 at 15:54
    
It is fully up to date. Is 10.8.2 the latest version, I'm at work so can't check. –  rf_wilson Feb 27 '13 at 16:13
    
Yes 10.8.2 is the latest –  MrDaniel Feb 27 '13 at 16:40

5 Answers 5

After upgrading to OSX 10.8.3 the sleep problem has gone away. Although due to other problems I have with external USB drives not reconnecting after sleep, I have turned off sleep and now leave it on 24/7.

share|improve this answer

Problem potentially fixed!

Progress bar appears after waking from sleep.

It is the new Safe Sleep feature.

To disable it:

  • Go to terminal
  • Type: sudo pmset -a hibernatemode 0
  • Enter your password when prompted
  • Type sudo rm /var/vm/sleepimage
  • Reboot

According to AppleCare, use sudo pmset -a hibernatemode 3 to reactivate Safe Sleep.

share|improve this answer

The Mini may not actually be asleep, instead the screen may just be deactivated.
I am seeing similar issues in my 10.8.3 Mini so I enabled remote ssh login.
I could remote login and run commands while supposedly the Mini was asleep.
I'll keep digging to try and find the root cause.

share|improve this answer
    
I have found the solution to this but the powers that be at stack exchange won't let me post it! I'll try again anyway - after I updated to 10.8.3 the problem has gone away. –  rf_wilson May 8 '13 at 12:49
    
Interesting, what happened when you tried to answer? –  nslntmnx May 9 '13 at 0:58
    
You are welcome to try to put your answer here apple.stackexchange.com/questions/90610 –  nslntmnx May 9 '13 at 0:59
    
It said "your post was converted to a comment" and its highlighted in red. There is an "undelete" option but its only a "vote" and that gets rejected. –  rf_wilson May 9 '13 at 14:49

Mac Mini / monitor problem SOLUTION! (I think)

I think I found the solution to the great Mac-Mini monitor that won't wake up after sleep problem, at least for an HP 2159m monitor and my Mac-Mini 5.1 --but probably for many Mac/monitor combinations. It appears to be just a simple timing problem between components. it has nothing to do with Mac firmware, NVRAM / PRAM or anything more exotic, it has to with how fast the Mac Mini comes online vs. the monitor itself.

Many monitors have a default setting to accept either VGA, DVI or HDMI or autodetect the input. Typical factory default monitor settings are to try to autodetect the input and, if no signal is detected, to default to VGA. My theory was that the monitor autodetected and defaulted before my Mac Mini fully started sending its HDMI signals.

My solution was to set the monitor (with the monitor's controls) to default to HDMI rather than VGA. After I did that the problem disappeared, now it wakes faithfully every time. Because it is expecting HDMI signals the Mac-Mini can take as long as it wants to start sending them.

share|improve this answer

Try resetting the NVRAM / PRAM as noted About NVRAM and PRAM

Resetting NVRAM / PRAM

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
  3. Turn on the computer.
  4. Press and hold the Command-Option-P-R keys before the gray screen appears. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
  5. Release the keys.

See if the sleep problem still occurs, if it does try resetting the SMC as noted Intel-based Macs: Resetting the System Management Controller (SMC).

Resetting the SMC for Mac Pro, Intel-based iMac, Intel-based Mac mini, or Intel-based Xserve

  1. Shut down the computer.
  2. Unplug the computer's power cord.
  3. Wait fifteen seconds.
  4. Attach the computer's power cord.
  5. Wait five seconds, then press the power button to turn on the computer.

If the problem still persists and you are running OS X Mountain Lion version 10.8.2, there may be a sleep bug that is effecting the reliability of sleep on a lot of Macs as discussed Problem with waking from sleep with 10.8.2

My Mac Pro (early 2009 2.66 GHz Quad-Core Intel Xeon) won't wake from deep sleep after installing OS X 10.8.2 . I have the default setting set for sleep. The only way to "wake" the machine is to hold the power button down to shut down and then restart. I've reset NVRAM (pram) and tried removing power cable. Nothing helps.

Since your Mac Mini is very new I would also consider contacting Apple Support and see what they offer as a solution and at the least notify them of the issue, I am sure they are working on a fix probably scheduled to be included with the next OS X update.

share|improve this answer
    
Is the NVRAM/PRAM method going to work with a wireless USB keyboard or do I need one that plugs in? –  rf_wilson Feb 27 '13 at 16:13
    
If its a wireless USB keyboard using a dongle plugged into the mac mini, it should work just fine, the mini won't know that its wireless. Also this should work with a properly configured Bluetooth keyboard also. –  MrDaniel Feb 27 '13 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.