Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Ok, this might be a stupid question to ask, but trying to mount a NFS share (from a Linux machine, if it's worth anything) in a folder that resides in /Volumes never makes the share appear in Finder (not in Volumes anyway).

The folder was made by simply sudo mkdir /Volumes/folder_name and the mount was made using autofs like this:

/Volumes/folder_name    auto_nfs      -nolock,locallocks,rdirplus

I should mention the folder is accessible though the terminal, but it just doesn't show in Finder.

On the other hand, if I modify /etc/auto_master to this:

/Volumes  auto_nfs      -nolock,locallocks,rdirplus

the folder appears, but I loose all my other drives (except the system one and Network)

At the moment, I'm mounting to a regular folder on the system drive which I've symlinked to a folder in /Volumes. Oddly, that works fine, but it does appear as a symlink and it bothers me (and possibly other users).

share|improve this question
    
Where in Finder are you looking /Volumes or the top level in Finder? ie if you show the fullpath in Finder what is at the top of the window? –  Mark Feb 26 '13 at 21:55
    
@Mark I need them appear at the top level in Finder (the actual machine), so that other users find them comfortably. I know OS X has a way of telling folders from drives, so just creating a folder in /Volumes does not work out of the box, but I don't know what that is. –  CatalinM Mar 4 '13 at 10:39
add comment

2 Answers

up vote 0 down vote accepted

There is a boring, technical explanation (which I cannot find right now) for this behavior . I worked around it by adding /Volumes to the Favorites section in the Finder's sidebar

enter image description here

share|improve this answer
    
Can you not mount NFS volumes through Finder's "Connect to Server" feature? I don't have an NFS share to attempt with. –  bispymusic Mar 2 '13 at 21:24
    
Unfortunately, this does not solve the problem, as I need the drives to be available when I click on the machine (under Devices). –  CatalinM Mar 4 '13 at 10:35
    
@bispymusic Yes I can, but it doesn't give me any mounting options, so I loose on performance visibly. Also, to have them automount on startup I have to add them to Login Items. –  CatalinM Mar 4 '13 at 10:37
    
@CatalinM Instead of mounting them as Login Items you can auto mount them at system boot time via the fstab file. Read the man page for fstab for more info. –  HairOfTheDog Mar 4 '13 at 17:09
    
@HairOfTheDog I thought about that, but last time I checked, there no fstab in /etc, like on my Linux machine. I learned ML uses autofs, so I worked with that. Maybe I missed something along the way? –  CatalinM Mar 5 '13 at 7:37
show 4 more comments

I have spent quite a bit of time figuring out automounts of NFS shares in OS X...

Somewhere along the line, Apple decided allowing mounts directly into /Volumes should not be possible:

/etc/auto_master (see last line):

#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static
/-          auto_nfs    -nobrowse,nosuid

/etc/auto_nfs (this is all one line):

/Volumes/my_mount    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://192.168.1.1:/exports/my_share

This will not work (anymore!) though it "should".

$ sudo automount -cv
...
automount: /Volumes/my_mount: mountpoint unavailable

What's the solution?

It's so easy my jaw dropped when I figured it out. Basically, we trick OS X into thinking we're mounting * somewhere else. *

When you're talking about paths in just about any environment, the root folder is the highest path you can reach, whether it's C:\ (windows) or / (*nix)

When you're at this path, attempting to reach the parent path, via .. will keep you at the root path.

For example: /../../../../ is still just /

By now, a few of you have already figured it out.

TL;DR / Solution:

Change your /etc/auto_nfs config from (this is all one line):

/Volumes/my_mount    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://192.168.1.1:/exports/my_share

To (this is all one line):

/../Volumes/my_mount    -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc nfs://192.168.1.1:/exports/my_share

And re-run the automounter:

$ sudo automount -cv
...
automount: /Volumes/my_mount: mounted

..... there you go! Technically /../Volumes is still /Volumes, but the automounter does not see things that way ;)

This configuration persists the mount across restarts, and creates the mountpoint automatically.

I KNOW, RIGHT?

share|improve this answer
    
I will try it this weekend! –  CatalinM Jan 30 at 22:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.