Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I started to experience problems with my iPhone that seem to be related to the dock connector.

Upon plugging my iPhone into my (officially supported) car stereo, I started to get the message "This accessory is not supported by iPhone" on the screen. Didn't think much of it as I only use it for charging purposes, and that still worked so I ignored it. Then I bought a small ANT+ dongle, which is a little accessory you plug into the dock connector to allow your phone to receive data from various health/fitness devices like heart rate monitor, and cycle sensors etc. It produces the same error message every time I plug it in, and the apps that use the dongle will not recognise it.

The dongle does officially support my hardware and OS level. I've checked that it is not broken by plugging it into an iPhone 5, an iPad 3 and an iPod of some description, none of which showed the error. The supported apps find the device on the iPad, the iPhone 5 does not have the apps installed but offers to do so as soon as I plug it in, so I know the dongle is working correctly.

In addition to the above, when nothing is plugged into the dock connector, it still occassionally thinks that something is, resulting in a muted phone. When it's in this state I am not able to hear anything or change any volume settings (music playback or ringer volume) with the physical keys. Going into the Music app shows that it thinks it's outputting the music to the dock connector.

Why is this accessory not working on my iPhone, and how can I get it working? What causes my iPhone to think that it's docked when it isn't?

share|improve this question

5 Answers 5

up vote 7 down vote accepted

This commonly occurs when there is an issue with your dock connector. It is likely dirty, obstructed in some way, or possibly even broken with a bent pin or something. Very often this is not apparent, because with 30 pins to play with, chances are most of the time you only need the ones for charging and USB data transfer, leaving the rest unused such that you will not notice if they start working sub optimally.

There are 3 ways I would try to fix this, in order of most likely to fix:

Clear it out

Your first step is to check for any obvious blockage. If you have a can of compressed air, you can try to blow any debris out. If you don't, then using a fine non metallic scraper (a plastic toothpick is ideal, a wooden one may leave small fibers behind) carefully clean out what you can - even if it looks clean you will be surprised how much crap and fluff you can scrape out. Take care to blow any debris out of the phone, and not into it - i.e. hold it upright and get at it from underneath, don't sit it upside down and work from the top

Clean it up

If there is no obvious obstruction then the problem may be more subtle, a coating on one or more of the pins that is preventing a neat conductive contact, or is grounding a pin against another one for example - perhaps there has been some contact with a liquid in the past etc. You need to clean the pins to get rid of this. You will need a couple of things things - 1) some cleaning agent, 2) a lint free cloth/piece of sponge, or an old toothbrush.

For a cleaning agent, 99% isopropyl is perfect, but if you don't have that kicking around you could try a very small quantity of the neatest and purest alcoholic drink you have in the house - I've used Vodka which is by and large 50/50 alcohol and water. Don't use anything flavoured or anything that it likely to have anything other than alcohol and water in it! Especially sugars or salt!.

Using a very small amount of your cleaning agent, and keeping the phone upright so any drips fall out, and not into the phone, lightly brush or wipe the dock connector, taking care not to be rough enough to disturb the pins out of alignment. I've used a small piece of synthetic sponge and prodded it about with the same toothpick I used earlier.

Hit it

If this doesn't work, then the issue could still be a physical obstruction, although it may be beyond the dock connector and more internal. Short of taking the phone to bits, there is not a lot you can do, and whilst you cannot clean the inside, you can try to dislodge anything that's stuck by using a combination of lightly tapping the phone on all 4 sides whilst playing about with the vibrate functions for alarms etc.


Using the first 2 methods above I solved the "Accessory not supported problem", but still had the intermittent docking issue.

Assuming I could not fix that one, I went to turn on Vibrate alerts (which I had previously turned off) as a workaround, only to find that after playing with all the vibrate "tones" etc it magically fixed itself!

  • Note 1 It's possible that the issue is not with the connector on your phone, but on your device/cable - you can try all the above on the cable end too if doing it on your phone does not yield results.
  • Note 2 If your device is failing to charge, or will only charge from a certain cable or dock, then the same fix potentially applies.
share|improve this answer

I had this same issue. I'm pretty sure from being in a damp pocket during a snowy 5k.
Here's what I did:
Turn the phone off
I used a concealer makeup brush dipped in alcohol to brush down the connector (while I was at it I also did the usb cord i use on my imac and the headphone jack).
Did a hard restart (hold down the power button and the home button for like 5 secs).
Hopefully this isn't a temporary fix!

share|improve this answer

Great tip, the trick with the alcohol did the trick for me inside my iPhone5. I used a toothbrush and dipped it in 70% alcohol and moved it around a lot on the connector side after turning my phone of first. After this I waited a minute and tested and it worked. Love you tips!

share|improve this answer

I have an iPhone 4S and I had the issue where it stopped connecting to any plg in device. I tried the cleaning, which did no harm, but then I messed around with the vibrate settings and it cleared immediately.

share|improve this answer
    
What might "messing around with the vibrate settings" entail if someone wanted to try that to solve their issue? –  bmike Jul 18 '13 at 10:47

In order for the line out audio to work for an iPhone 5 or 5s dock, make sure you have iOS 7. I had iOS 6 running on the iPhone 5 and the line out audio would not work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.