Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Macbook Pro 13 mid-2012. It was shipped with a 500GB HDD, to which I added an additional SSD drive (128GB). After installing my SSD in a caddy, thus replacing the optical drive, I installed a new installation of OS X on my brand new SSD. I kept the OS X partition on the original HDD, as I wanted to keep my personal files.

Then I installed Windows in a Bootcamp partition on the HDD, as Windows doesn't seem to be working properly when installed on a hard drive which is not on SATA 0 bay (the SSD is on SATA 1).

I wanted to install Ubuntu, which I've been able to do on the SSD. I had to install rEFInd in order to allow this triple-boot configuration to work.

As I am an ever-changing geek, I wanted to install Linux Mint instead of my Ubuntu. The problem is that it doesn't appear to be as easy as Ubuntu. I wasn't able to boot on my fresh Mint after installation completed.

I first tried to install the GRUB loader on the legacy Recovery HD partition on the HDD (which became useless since I got a new one on the SSD when I reinstalled OS X), then I tried to install it on the same partition as Mint, and finally I tried without installing any GRUB. None of these worked.

Here is the actual disks partitioning scheme. Please note that the is a 650MB unallocated partition between disk0s2 and disk0s3, which is not shown by diskutil. It used to be a Windows system partition.

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Datas                   349.0 GB   disk0s2
   3:       Microsoft Basic Data BOOTCAMP                150.2 GB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *128.0 GB   disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                  Apple_HFS MacX                    90.0 GB    disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
   4:       Microsoft Basic Data                         37.2 GB    disk1s4

I am trying to install Mint on disk1s4. As I said previously, there is a free gap of 650M between Datas and BOOTCAMP, which can be used to install a GRUB loader, if needed.

I would appreciate any help or lead, as long as it is not "reinstall the whole thing".

Thank you.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.