Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have OS X 10.5.8 on a 2.8 GHz Intel Core 2 Duo Mac, and I need to install iTunes 10.7 but it won't let me. I need to connect my iPad 4 and iPod nano to iTunes but it won't allow me unless I can upgrade to iTunes 10.7.

Does anyone have had the same problem but managed to overcome it?

share|improve this question
1  
What does "it won't let me" mean? Do you get an error message? –  patrix Feb 24 '13 at 11:18
add comment

1 Answer

iTunes 10.7 requires OS X 10.6.8 or later:

http://support.apple.com/kb/DL1576?viewlocale=en_US&locale=en_US

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.