Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have 1mbps connection at home. When I connect my laptop or mobile with wifi I get around 120kBps speed which is ok. But when I connect my MAC book with the same wifi I get no more than 20-30kBps speed. Same thing happens at office too. There we have 10mbps line but I get same 20-30kBps speed.

Today I am even seeing some strange issues as well. I tried opening wikipedia.org and it showed me only text, css and .js was stripped out. Again I tried opening the page and it opened perfectly. I can't open gmail and facebook at all. But I can access these sites in my laptop right now.

I talked with the admin guy, but he says he did nothing as such.

What could be the issue? How to debug it?

FYI:
When I am at home I am not behind any proxy.
I don't have admin rights, so the solution you will give I will pass on to the admin guy. That may help him.

More
Just now I pinged www.google.com and it returned:-

Ping has started…

ping: cannot resolve www.google.com: Unknown host

But again I can access all sites in laptop.

share|improve this question
    
Many major web sites are proxied and routers or the OS itself discard ping responses. You might try traceroute or host rather than using ping to test connectivity. –  bmike Feb 21 '13 at 16:40
add comment

1 Answer 1

In general, I have high regard for Apple's network diagnostic tool.

Open system preferences and go to Network.

Network preference pane

Mash the Assist me.. button and run diagnostics.

It will help you provide detailed status to your network admin or perhaps show you what step along the way is failing.

share|improve this answer
    
Great! I will surely tell this to admin guy. :) Thanks. –  Rakesh Juyal Feb 21 '13 at 16:52
    
Also, I see in DNS server tab there are 2 DNS servers mentioned. One which is the IP of my wifi. Then there is one more DNS server which I don't what is that. It is fe80::a221:b7ff:febc:d368 . Can this be an issue? –  Rakesh Juyal Feb 21 '13 at 16:56
    
If your DNS is messed up, that would surely be a problem. Most people can turn off IPv6 and be just fine, but it's rare to have an IPv6 DNS poison things on a Mac as it's pretty smart about trying IPv4 first for name resolution. –  bmike Feb 21 '13 at 16:58
    
I tried Assis me > diagnostics . It says "Your Internet connection appears to be workig correctly' I still can't connect to facebook. But using Laptop I can connect right now. Help please. –  Rakesh Juyal Feb 21 '13 at 17:08
    
I deleted 'fe80::a221:b7ff:febc:d368' from DNS server list, and now somwhow I can access facebook and gmail both. Speed is still throttled to 20kBps. –  Rakesh Juyal Feb 21 '13 at 17:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.