Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iMac mid 2011 at home. When I was not home, I may need to access my mac with Screen Sharing. However the iMac display will turn itself on when I connect via Screen Sharing. The problem is I don't want to scare my family at home (with the elders and kids) as the iMac "turn itself on suddenly".

This is a problem specific for iMac. On MacBooks (Pro, Air, whatever) I can set the brightness to the lowest setting so the screen is black (i.e. the LED light is off). However on an iMac you cannot turn off the LED backlit by setting brightness. The display is still bright and everything is clearly visible even on lowest brightness setting.

Therefore these solution are not working as the display will turn on as soon as you move your mouse or hit any key on the keyboard via Screen Sharing.

Question: Is the a way to keep the iMac display off entirely while you accessing it with Screen Sharing?

share|improve this question
    
What if somebody else in your family is using the computer when you VNC in? Won't they have to change the brightness (or get upset it is changing on them unexpectedly while they are trying to use the computer), thereby negating the solution until you manually reinstate it later? –  Michael Jan 7 at 23:52

7 Answers 7

OS X Lion added per-user screen sharing: the ability to have multiple remote desktop sessions active on a single Mac at the same time. It's not a perfect solution, but you may find it good enough for your case.

When you connect to your Mac via Screen Sharing make sure the session is in Control Mode, not View Mode. You can switch modes by pressing Cmd+Option+X in the Screen Sharing app.

Once in Control Mode, look under the View menu and you should see an entry that says "Switch to Virtual Display". Select that to change the session to a virtual display, not the current desktop display, and log in as yourself.

The main display on your iMac should go to sleep according to your screen saver and energy settings once you've disconnected your remote session from the physical display and moved it to a virtual display.

The only flaw in this approach is I know of no way to start Screen Sharing on a virtual display from the get go. So the initial connect always wakes up the physical display.

Update for Mavericks

The "Switch to Virtual Display" option in the Screen Sharing app when away in Mavericks. Instead, upon connecting to the other Mac with Screen Sharing:

If someone else is already connected to the Mac as a remote user, a dialog asks if you want to share the display with the other remote user (Share Display), or log in concurrently using a different user name and screen (Log In). Choose the option you want.

If you choose Log In, you will share the Mac with the other remote user, but you won’t share the same screen.

Here's an example. In this case I tried to connect a Screen Sharing session from my iMac to my wife's MacBook Pro where she was already logged in. This is the dialog I get when trying to connect:

Screen Sharing in Mavericks

share|improve this answer
    
I don't have a 'Switch to Virtual Display' option in the View menu...did this go away with some OS update? –  RyanStochastic Jul 30 '13 at 19:22
    
I double check in Mountain Lion when I get home. Pretty sure it was there. –  Ian C. Jul 30 '13 at 19:36
    
Same here, cannot find the option "Switch To Virtual Display", I'm in Mavericks –  yorch Dec 16 '13 at 21:01
    
This solution requires the connecting client to be running Mac OS X, no? I have this problem from an Android client; it speaks the right protocol to directly log in as a different user than who is currently on the screen, but the "password" box for the other user pops up every time I do something from VNC... –  Michael Jan 7 at 23:44
    
@Michael yes: both machines must be running OS X. –  Ian C. Jan 8 at 2:04

Jolly's Fast VNC client has an option under the Advanced preferences called "Enable Remote Screenlock" that sounds exactly like what you're describing.

Another possible solution is a password-protected screensaver with a short timeout. That way if you leave your station logged-in and unattended, it will lock itself down.

share|improve this answer
    
I'd like it server side. –  Max Ried Oct 14 '12 at 14:18
    
This doesn't keep the light off on the computer being controlled, but it does shroud things for privacy from a local observer. –  bmike Jan 8 at 4:10

This is not a perfect solution but I believe this is a best solution so far.

My use case is to use iMac remotely from my Windows 7 laptop.

Here is my solution.

You need the following things.

  1. Vine VNC Server from http://www.testplant.com/products/vine/vine-server/. You need another VNC server to make another private display.
  2. Wake Up Me On utility from http://www.nirsoft.net/utils/wake_on_lan.html. This is a windows utility but I think there is a similar one for OSX.
  3. Turn on “Wake for network access” on Energy Saver of System Preferences and set Computer sleep to Never. if this is not never, iMac goes to sleep shortly after VNC connecting.
  4. You may need to activate Fast User Switching.

Here are the steps.

  1. Install Vine VNC server. (actually copy it to somewhere in your mac)
  2. Launch Vine VNC Server and open preference of the VNC server and go to connection
  3. Select 1 from Display Number and enter 5901 to the port. Do not use 0 as the display number. Display 0 means the main console. i.e. the monitor.
  4. Set the VNC password.
  5. Start Vine VNC server.
  6. Launch VNC client. I am using Real VNC viewer but it does not matter.
  7. Type your mac host name or IP address and :1 (1 means the display number) For example, if your mac host name is iMac or the IP address is 192.168.1.20, this will be iMac:1 or 192.168.1.20:1
  8. Check if everything is working well and then close the VPN client.
  9. Switch to Logon window.
  10. Sleep iMac by clicking Sleep on the bottom <- this is very important. Just turning off the monitor using Ctrl-Shit-Eject does not work.
  11. Wake up the iMac using the Wake Up Me On utility.
  12. Connect to iMac again.
  13. Now you can use iMac and the monitor is still off.

The key of this solution is to sleep iMac when you leave and wake it up through network access (iMac works as normal after waking up but the monitor is still off) so this may not work out of a local network.

(I have confirmed this works on a 27" late 2012 iMac with the Mountain Lion).

share|improve this answer
    
I'm kinda put off by having to install a different VNC server on my Mac for just this one problem, when there's already a VNC server that does everything I wanting including logging in as a different user. –  Michael Jan 7 at 23:46
    
@Michael Unless someone figures out how to hack the Apple supplied VNC server, this might be the only option. –  bmike Jan 8 at 4:11
    
Does Vine Server support Mavericks? The download link (had to given them my e-mail, yeck) only claims "supports Mac OSX 10.6, 10.7, 10.8". –  Michael Jan 8 at 16:00
    
I'm not sure I understand the whole "put the Mac to sleep" part, and it seems like this approach definitely won't work if the machine might be woken up by somebody else in the office before trying to VNC in. Ignoring the put to sleep part, I find that after the display sleeps, connecting to the Vine VNC server causes the display to wake up, but only for a second at a time for each mouse event, but then it wakes up longer for key strokes. I am still struggling to understand why VNC access on a different (non-console) port would even affect the screen! –  Michael Jan 8 at 16:15

Here's a dirty way to do this (since the Virtual Desktop option is only available when there's more than 1 person logged in): On the Mac you want to access, create a Guest User account, and log on this account. When you screen share to this Mac, it'll ask you if you want to share the display or connect to a virtual display. Choose the latter. The Guest User account will be the one that's displayed on the Mac screen.

share|improve this answer
    
My Android VNC client doesn't ask, it just automatically logs me in to my account (which isn't the one displayed), yet I still have this problem. –  Michael Jan 7 at 23:50
    
@Michael This is documented on the site: apple.stackexchange.com/questions/19618/… Many VNC clients do not support Apple's extension for picking between multiple users. –  bmike Jan 8 at 4:14

Logmein has an option to blank the host display: https://secure.logmein.com/welcome/webhelp/pro/LogMeIn/t_remotecontrol_blank.html

share|improve this answer

I have found a workaround, but that's not perfect. With Brightness Control (freeware), I can make my screen black while everything is still visible via Screen Sharing. However it didn't turn off the LED light. A black screen with the LED backlit on is still drawing enough attention in the evening.

share|improve this answer

Instead of turning the computer off, or putting it in sleep mode, you could consider just turning the display off.

There is a key combination that you can use to turn the screen off which is: ctrl + shift + eject.

share|improve this answer
1  
The display will "wake up" as soon as you move your mouse or type on the keyboard via Screen Sharing, so this didn't work :( –  howanghk Feb 21 '13 at 18:10
    
    
oops it is weekend and I am out of town atm, will try it after I get home on Sunday night, thanks in advance. –  howanghk Mar 1 '13 at 20:15
    
sure, however im 99% it will work! what it does, is that it actually dont put your display to sleep,and therfore you wont "wake it" it will just lower it to ridiculously low amounts, and the display is practically off! –  Macmaniman Mar 3 '13 at 12:37
    
I am sorry to tell you that the "Brightness Slider" didn't work. On my iMac with the lowest brightness with this app does not dim the mouse cursor, and I have taken a photo for that funny effect: cl.ly/NJGl –  howanghk Mar 3 '13 at 19:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.