Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iMac with the 10.4 OSX operating system installed. When I boot the computer it prompts me with this message: "Your startup disk is full. You need to make more space available on your disk by deleting files". I am able to login and see the desktop background, but I cannot see any menus.

How can I delete files or erase all the data? I have the startup disks but when I hold down C as the disks instructions say, nothing when I reboot.

share|improve this question
up vote 2 down vote accepted

Try deleting files in single user mode:

  • Restart
  • Hold ⌘S after hearing the startup sound (it doesn't work if I start holding it before the computer has restarted)
  • Run mount -uw / (fsck -fy is not needed)
  • Run something like rm -r /Users/username/.Trash/
  • reboot
share|improve this answer
It's prompting me for "override rw-rw-rw 501/staff for /foldername/filename/here.extension" I've pressed "Y" and enter on each file but after reboot, I'm still out of space. I ran the command again, but all of the same files get prompted again for this questions. Any ideas? – Victor Feb 18 '13 at 23:44
I'm also trying: rm -rf /Users/username/.Trash/ But it's coming back with the "Read-only file system" comment on each file – Victor Feb 18 '13 at 23:57
It worked for me (on 10.8). The -w option of mount -uw / should mount the filesystem as writable. – user495470 Feb 19 '13 at 0:19
Somehow I missed the trailing "/" on the mount -uw command. Thanks, that worked! – Victor Feb 19 '13 at 0:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.