Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 3rd gen 32GB iPad with a 3G/LTE connectivity (and the latest software) and let me be clear from the start - the WiFi is working perfectly fine for me and I've had no problems with it whatsoever.

The problem is with my iPad causing quite a serious WiFi interference for some other devices on one WiFi network (at my friend's house). It happens only on this single WiFi network and I am 100% sure it is my iPad causing the problems.

Basically, the moment my iPad connects to the WiFi several other devices connected to the network drop their WiFi connection. These are: a Samsung TV and 2 laptops (HP and Dell).

What's interesting, there are several other devices that don't experience no such issues with the WiFi connection, e.g. a couple of iPhones, few other laptops and other mobile devices, including another 3rd gen iPad with 3G/LTE (similar to mine, just 16GB).

If I switch off the WiFi on my iPad and wait a minute or two, all the other devices resume normal WiFi connection.

Any idea what could be causing such problems?

I've already tried resetting network settings.

share|improve this question

6 Answers 6

I doubt highly that it is the iPad causing interference. What I could expect is that the base station at your friends place can't keep up with all the wireless devices at once. If the TV is using 802.11g as are the other devices that disappear and then your iPad using 802.11n then the base station might crap out. Have seen a few similar cases before.

Additionally some base stations have limitations, example older AirPort Expresses could manage 5 or 10 clients. Once an 11th device comes into the network then a device or two or more might be kicked out because of the DHCP TTL time out. Going static with your IP address won't fix this, only a better base station, eg. the newer Express or Extreme.

share|improve this answer

I have had the same experience and today seems like I solved with the help of a friend of mine.

Just try to set static IP-address on other users, if they are used always in the same place. This solved my problem. I realized that if I power off the iPad, the WiFi on my desktop worked properly.

share|improve this answer
DHCP issues - that's what I thought, unfortunately static IP is a no go :( – Michal M Mar 28 '13 at 13:33

Do you have an HP printer with wifi? I have an Office Jet Pro 8600.

Turning off WiFi printing fixed the WiFi issue.

share|improve this answer
Are you sure this is answering to the original question ? – daniel Azuelos Sep 3 '14 at 13:51

Well I found the problem - your iPad saves every program in the background even after you have turned off and started the ipad again. So things like games that are connecting to facebook, youtube, your mail etc etc it all adds up.

first time I checked I had about 40 programs running in the background - shut them all down and problem solved!

double click the home button and swipe up to shut down a program

share|improve this answer

f you have a dual band router then set the ipad to use the 5GHz band, this worked for me.

My Ubuntu laptop with a RTL8192EE wireless device driver does not support use of the 5Ghz band and whenever the ipad was in use with the 2.4GHz wifi signal the laptop lost wifi connectivity or ran extremely slowly and then lost connectivity.

This was repeatable and confirms that the ipad (air 2) does not play nicely with another wifi device using the same 2.4GHz router signal.

share|improve this answer

Wifi trouble shooting (which I used to do for a living a few years ago) can be a little lengthy.

There are a few settings that may need to be adjusted and checked. The problem with wifi is that there is no physical way to stop any device from transmitting. One issue may be the device that you suspect is causing the noise is just not following wifi standards correctly (some apple devices I've seen do this and I've also talked to fellow PC wifi experts from aruba networks that have confirmed my suspicions that apple products just don't play nice with non apple products. At least from 2014 and before.). Basically there are a few settings you might want to check.

  1. Long and short preamble. Generally setting this to long will fix a large number of drop out issues.Long preamble will make your connection have a slightly longer ping time.. I doubt you'll notice really. I suggest you consult your wifi devices on how to check for this setting. These is no point in having a faster ping time if the connection keeps dropping out. recovering the connection from a drop out causes a much much longer ping time than not.

  2. make sure every device is set to wireless N MODE. wireless G mode is prone to drop outs and won't handle as many simultaneous devices as gracefully as the updated N standard.

  3. Have you got the newest/known working firmware on your wifi device? I've encountered a few devices over the last 5 or so years that have random drops caused by apple devices and bad firmware. I've just had to flash my cheap tenda w308R wifi router as a new house mate has an apple laptop and it keeps causing the router to revert back to wpa-psk mode and not wpa2-psk mode. You MUST SET wpa2-psk for wireless N mode other wise you'll only enjoy about 52mb/s rather than 120mbs or more. This was a bug with the tenda device how ever and as I've now flashed it it's stable again.

  4. Try switching between Wireless N only and wireless N mixed mode. Usually wireless N only is the much much preferred mode as it will have less drops and be about 2 or 3 times faster etc. Don't forget you need WPA2-PSK to be set for security or this just won't work correctly. (it's in the wireless N specs)

  5. Turn off all wifi power saving modes. If the wifi device is a usb device then also turn off any USB power saving modes. If this fixes your problem then it's the operating system/device drivers misbehaving and causing your drops. Not much you can do there except update the software and see if it fixes it.

  6. If turning off the power saving modes don't work then try setting the max transmit power settings a little lower and see if that helps. some times a wifi device may sent a too strong signal and that actually may cause interference. I usually find this is rare though.

  7. Try another version of your wifi driver software. even if it's an older version it might fix the issue. A few years ago I had about 3 drivers from realtek cause wifi drops. After reverting back a few versions the issue just didn't come back. I tried upgrading back to the newer versions and the problem was back. luckily they fixed that issue in a further 6months after that was an issue. So not every upgrade is a good upgrade.

Well. that's most of the tricks you can try.

share|improve this answer
How can these findings be used to specifically reconfigure an iPad in order to reduce WiFi interference? – patrix Sep 14 at 9:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.