Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I open a Save as dialog, Finder starts to scan my external TimeMachine drive which needs to "boot up" some seconds. This makes the dialog very unresponsive, because it waits for the drive to be ready.

Is it possible to disable the TM drive for such things and just allow the TimeMachine feature for it?

share|improve this question

1 Answer 1

The following MAY work.

Pre-requisites:

  • Root access, either by enabling the root user account or through a root shell.

  • If through shell, you need familiarity with a command line text editor. Mac's ship with vim and nano that I know off.

Method:

Edit /etc/fstab. The file doesn't exist by default.

Create an entry for the time machine disk. See man fstab for full details.

The option you want to add to options is 'nobrowse'

This disables it from showing in the finder an may also help you with the save issue.


I have not tested this, and don't plan to, as I keep all of my disks spinning. While disks are rated in terms of mean time before failure, they really should be rated in terms of spin-up/down cycles. In my years as a sysadmin I insisted on leaving machines on, disks spinning. I had FAR fewer disk replacements than departments where they spun them down at night.

Time machine is going to make a backup every hour, and so will spin up the disk, unless no file has changed in the last hour.

share|improve this answer
    
Thank you for your response. Looks very promising. I'll check that. –  binarious Mar 19 '13 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.